summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/nfft/nfft-3.5.2.ebuild')
-rw-r--r--sci-libs/nfft/nfft-3.5.2.ebuild17
1 files changed, 5 insertions, 12 deletions
diff --git a/sci-libs/nfft/nfft-3.5.2.ebuild b/sci-libs/nfft/nfft-3.5.2.ebuild
index f0ea656c7539..066540701d6c 100644
--- a/sci-libs/nfft/nfft-3.5.2.ebuild
+++ b/sci-libs/nfft/nfft-3.5.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,18 +18,11 @@ RDEPEND="sci-libs/fftw:3.0[threads,openmp?]"
DEPEND="${RDEPEND}"
pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
- if ! tc-has-openmp; then
- ewarn "OpenMP is not available in your current selected compiler"
-
- if tc-is-clang; then
- ewarn "OpenMP support in sys-devel/clang is provided by sys-libs/libomp,"
- ewarn "which you will need to build ${CATEGORY}/${PN} with USE=\"openmp\""
- fi
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
- die "need openmp capable compiler"
- fi
- fi
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_configure() {