summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/onnx')
-rw-r--r--sci-libs/onnx/files/onnx-1.14.0-cxx_14.patch11
-rw-r--r--sci-libs/onnx/onnx-1.13.1-r1.ebuild (renamed from sci-libs/onnx/onnx-1.13.1.ebuild)2
-rw-r--r--sci-libs/onnx/onnx-1.14.0-r1.ebuild (renamed from sci-libs/onnx/onnx-1.14.0.ebuild)2
3 files changed, 15 insertions, 0 deletions
diff --git a/sci-libs/onnx/files/onnx-1.14.0-cxx_14.patch b/sci-libs/onnx/files/onnx-1.14.0-cxx_14.patch
new file mode 100644
index 000000000000..239e0bd3a56a
--- /dev/null
+++ b/sci-libs/onnx/files/onnx-1.14.0-cxx_14.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt 2023-09-01 12:19:40.772172388 +0200
++++ b/CMakeLists.txt 2023-09-01 12:19:53.422188861 +0200
+@@ -58,7 +58,7 @@
+ # Required to use /std:c++17 or higher on Windows
+ # For other platforms, set C++11 as standard for the whole project
+ if(NOT MSVC)
+- set(CMAKE_CXX_STANDARD 11)
++ set(CMAKE_CXX_STANDARD 14)
+ else()
+ string(APPEND CMAKE_CXX_FLAGS " /std:c++17")
+ endif()
diff --git a/sci-libs/onnx/onnx-1.13.1.ebuild b/sci-libs/onnx/onnx-1.13.1-r1.ebuild
index cee6ddd5c494..1de081f5931b 100644
--- a/sci-libs/onnx/onnx-1.13.1.ebuild
+++ b/sci-libs/onnx/onnx-1.13.1-r1.ebuild
@@ -22,6 +22,8 @@ BDEPEND="
${PYTHON_DEPS}
"
+PATCHES=( "${FILESDIR}"/${PN}-1.14.0-cxx_14.patch )
+
src_configure() {
local mycmakeargs=(
-DONNX_USE_PROTOBUF_SHARED_LIBS=ON
diff --git a/sci-libs/onnx/onnx-1.14.0.ebuild b/sci-libs/onnx/onnx-1.14.0-r1.ebuild
index 866f8a5e90fd..bed797b68a21 100644
--- a/sci-libs/onnx/onnx-1.14.0.ebuild
+++ b/sci-libs/onnx/onnx-1.14.0-r1.ebuild
@@ -22,6 +22,8 @@ BDEPEND="
${PYTHON_DEPS}
"
+PATCHES=( "${FILESDIR}"/${P}-cxx_14.patch )
+
src_configure() {
local mycmakeargs=(
-DONNX_USE_PROTOBUF_SHARED_LIBS=ON