summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/lrslib/Manifest2
-rw-r--r--sci-libs/lrslib/lrslib-042c-r2.ebuild60
-rw-r--r--sci-libs/lrslib/lrslib-051.ebuild44
3 files changed, 0 insertions, 106 deletions
diff --git a/sci-libs/lrslib/Manifest b/sci-libs/lrslib/Manifest
index 7a3ea7bd1f8f..e6fd1344b669 100644
--- a/sci-libs/lrslib/Manifest
+++ b/sci-libs/lrslib/Manifest
@@ -1,3 +1 @@
-DIST lrslib-042c.tar.gz 168765 BLAKE2B d9ac0d59e4ca356f4cf76fa4f3756b6badd79a8c8546b7bd3a2dc65d211af30d354b9829395e68d79bb5acf24ba2087ca4d8a390a7c7d98e6cad86d0f9a27eac SHA512 a5fdd65b2c4e4cadd5fb9679e0e94ddc6b3564cdb9bdfcb7304351fec943527d2dccf117148d8d418ad8bd4577c9f69dabd6ca07107c1c1555c8c6d17f38fa60
-DIST lrslib-051.tar.gz 179396 BLAKE2B 22697dc4e99bf9ae528328c1a03e87f5101b1e0c74cbee9c7dafb5e1c897ad07587e9664abd9710094a6fe78cba0cff48c0489f687bedb616886101286153cc6 SHA512 65e4752ae75f06bccb74b0e12e0b03943654cba048d54dbcf93a36bea7f73b32826babe066d5fe20d3c6609548dc957063558633affe64d795c240c1fe748927
DIST lrslib-062.tar.gz 292745 BLAKE2B 1a2c0e264d590c38d83ee35616b1ec36d8a093b5c7f08179019261d8b321d5b95d8889ca6555ae69853f919d6d66358a865a8a2002516dfd560bec6658f3913d SHA512 1d644a7798580457ff266730f42f6fac317ec8cdf2509ad6028e7a838e5c4c948bd0f9499b840c227bad4269f7144ff72b87fe3a19bdb9ad0925ebe4a7bc4f9f
diff --git a/sci-libs/lrslib/lrslib-042c-r2.ebuild b/sci-libs/lrslib/lrslib-042c-r2.ebuild
deleted file mode 100644
index 8fafdff0cba2..000000000000
--- a/sci-libs/lrslib/lrslib-042c-r2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit toolchain-funcs
-
-DESCRIPTION="self-contained ANSI C implementation of the reverse search algorithm"
-HOMEPAGE="http://cgm.cs.mcgill.ca/~avis/C/lrs.html"
-SRC_URI="http://cgm.cs.mcgill.ca/~avis/C/lrslib/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="gmp"
-
-DEPEND="gmp? ( dev-libs/gmp )"
-RDEPEND="${DEPEND}"
-
-src_prepare(){
- sed -i "s/gcc/$(tc-getCC)/g" makefile || die
- sed -i "s/-O3/${CFLAGS} ${LDFLAGS}/g" makefile || die
- # We don't like static linking to gmp or anywhere.
- if use amd64 ; then
- # This macro may only change messages that the
- # binary outputs, but just in case... (Bug 384195)
- sed -i "s/-static/-DB64/g" makefile || die
- else
- sed -i "s/-static//g" makefile || die
- fi
-}
-
-src_compile () {
- if use amd64 ; then
- emake all64
- else
- emake
- fi
- if use gmp ; then
- emake gmp
- fi
-}
-
-src_install() {
- dobin lrs redund redund1
- # Collides with sys-block/buffer
- newbin buffer lrsbuffer
- if use x86; then
- dobin nash setupnash setupnash2 2nash
- # Prevent clash with cddlib:
- newbin fourier lrsfourier
- fi
- if use gmp; then
- dobin glrs gredund gfourier
- # Clash with www-plugins/gnash
- newbin gnash lrsgnash
- fi
- dodoc readme
- dohtml lrslib.html
-}
diff --git a/sci-libs/lrslib/lrslib-051.ebuild b/sci-libs/lrslib/lrslib-051.ebuild
deleted file mode 100644
index 8c8e791b7941..000000000000
--- a/sci-libs/lrslib/lrslib-051.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit toolchain-funcs
-
-DESCRIPTION="self-contained ANSI C implementation of the reverse search algorithm"
-HOMEPAGE="http://cgm.cs.mcgill.ca/~avis/C/lrs.html"
-SRC_URI="http://cgm.cs.mcgill.ca/~avis/C/lrslib/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="gmp"
-
-DEPEND="gmp? ( dev-libs/gmp:0= )"
-RDEPEND="${DEPEND}"
-
-src_prepare(){
- sed -i "s/gcc/$(tc-getCC)/g" makefile || die
- sed -i "s/-O3/${CFLAGS} ${LDFLAGS}/g" makefile || die
- # Prefix for install
- sed -i "s,/usr/local,/usr,g" makefile || die
-}
-
-src_compile () {
- if use gmp ; then
- emake all
- emake all-shared
- else
- emake allmp
- fi
-}
-
-src_install() {
- dodoc readme
- # Library
- if use gmp ; then
- emake DESTDIR="${D}" install-shared
- fi
- # Install default set of binaries
- emake DESTDIR="${D}" install-common
-}