summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/clapack/clapack-3.2.1-r6.ebuild41
-rw-r--r--sci-libs/clapack/files/clapack-3.2.1-findblas-r6.patch50
2 files changed, 0 insertions, 91 deletions
diff --git a/sci-libs/clapack/clapack-3.2.1-r6.ebuild b/sci-libs/clapack/clapack-3.2.1-r6.ebuild
deleted file mode 100644
index 57fb494bff40..000000000000
--- a/sci-libs/clapack/clapack-3.2.1-r6.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-inherit flag-o-matic cmake-utils
-
-DESCRIPTION="f2c'ed version of LAPACK"
-HOMEPAGE="http://www.netlib.org/clapack/"
-SRC_URI="http://www.netlib.org/${PN}/${P}-CMAKE.tgz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
- >=dev-libs/libf2c-20090407-r1
- virtual/blas"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${P}-CMAKE
-
-PATCHES=(
- "${FILESDIR}/${P}-fix_include_file.patch"
- "${FILESDIR}/${P}-noblasf2c.patch"
- "${FILESDIR}/${P}-hang.patch"
- "${FILESDIR}/${P}-findblas-r6.patch"
-)
-
-# bug 433806
-RESTRICT="test"
-
-src_configure() {
- filter-flags -ftree-vectorize
- # causes an internal compiler error with gcc-4.6.2
-
- local mycmakeargs=( $(cmake-utils_use_enable test TESTS) )
- cmake-utils_src_configure
-}
diff --git a/sci-libs/clapack/files/clapack-3.2.1-findblas-r6.patch b/sci-libs/clapack/files/clapack-3.2.1-findblas-r6.patch
deleted file mode 100644
index 028dec609dd8..000000000000
--- a/sci-libs/clapack/files/clapack-3.2.1-findblas-r6.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-diff -ruN clapack-3.2.1-CMAKE.1.allexfb/CMakeLists.txt clapack-3.2.1-CMAKE/CMakeLists.txt
---- clapack-3.2.1-CMAKE.1.allexfb/CMakeLists.txt 2011-06-19 22:13:27.000000000 +0200
-+++ clapack-3.2.1-CMAKE/CMakeLists.txt 2011-06-19 22:23:14.000000000 +0200
-@@ -30,6 +30,29 @@
-
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fPIC")
-
-+if(BLAS_LIBRARIES)
-+ include(CheckFortranFunctionExists)
-+ set(CMAKE_REQUIRED_LIBRARIES ${BLAS_LIBRARIES})
-+ CHECK_FORTRAN_FUNCTION_EXISTS("dgemm" BLAS_FOUND)
-+ unset( CMAKE_REQUIRED_LIBRARIES )
-+ if(BLAS_FOUND)
-+ message(STATUS "--> BLAS supplied by user is WORKING, will use ${BLAS_LIBRARIES}.")
-+ else(BLAS_FOUND)
-+ message(ERROR "--> BLAS supplied by user is not WORKING, CANNOT USE ${BLAS_LIBRARIES}.")
-+ message(ERROR "--> Will use REFERENCE BLAS (by default)")
-+ message(ERROR "--> Or Correct your BLAS_LIBRARIES entry ")
-+ message(ERROR "--> Or Consider checking USE_OPTIMIZED_BLAS")
-+ endif(BLAS_FOUND)
-+else(BLAS_LIBRARIES)
-+ # User did not provide a BLAS Library
-+ find_package(PkgConfig)
-+ pkg_check_modules(BLAS blas)
-+endif (BLAS_LIBRARIES)
-+
-+if(NOT BLAS_FOUND)
-+ message(FATAL_ERROR "--> BLAS libraries needed but not found.")
-+endif(NOT BLAS_FOUND)
-+
- add_subdirectory(SRC)
-
- if(ENABLE_TESTS)
-@@ -44,4 +67,3 @@
- ${CLAPACK_BINARY_DIR}/clapack-config-version.cmake @ONLY)
- configure_file(${CLAPACK_SOURCE_DIR}/clapack-config.cmake.in
- ${CLAPACK_BINARY_DIR}/clapack-config.cmake @ONLY)
--
-diff -ruN clapack-3.2.1-CMAKE.1.allexfb/SRC/CMakeLists.txt clapack-3.2.1-CMAKE/SRC/CMakeLists.txt
---- clapack-3.2.1-CMAKE.1.allexfb/SRC/CMakeLists.txt 2011-06-19 22:13:44.000000000 +0200
-+++ clapack-3.2.1-CMAKE/SRC/CMakeLists.txt 2011-06-19 22:15:04.000000000 +0200
-@@ -380,7 +380,7 @@
- endif()
-
- add_library(clapack SHARED ${ALLOBJ} ${ALLXOBJ})
--target_link_libraries(clapack blas f2c m)
-+target_link_libraries(clapack ${BLAS_LIBRARIES} f2c m)
- set_target_properties(clapack PROPERTIES SOVERSION "${CLAPACK_VERSION}")
-
- install(