summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/diagrtb')
-rw-r--r--sci-mathematics/diagrtb/diagrtb-2.64.ebuild12
-rw-r--r--sci-mathematics/diagrtb/files/CMakeLists.txt1
2 files changed, 7 insertions, 6 deletions
diff --git a/sci-mathematics/diagrtb/diagrtb-2.64.ebuild b/sci-mathematics/diagrtb/diagrtb-2.64.ebuild
index 7d68ff7897a9..59b01102533f 100644
--- a/sci-mathematics/diagrtb/diagrtb-2.64.ebuild
+++ b/sci-mathematics/diagrtb/diagrtb-2.64.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils fortran-2
+inherit cmake fortran-2
DESCRIPTION="Calculation of some eigenvectors of a large real, symmetrical, matrix"
HOMEPAGE="http://ecole.modelisation.free.fr/modes.html"
@@ -17,10 +17,12 @@ RESTRICT="mirror bindist"
S="${WORKDIR}"/Source_RTB2011
+DOCS=( diagrtb.README )
+
src_prepare() {
cp "${FILESDIR}"/CMakeLists.txt . || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -28,5 +30,5 @@ src_configure() {
-DEXAMPLES=$(usex examples)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/sci-mathematics/diagrtb/files/CMakeLists.txt b/sci-mathematics/diagrtb/files/CMakeLists.txt
index d1eb6c62f09f..ef022328bce9 100644
--- a/sci-mathematics/diagrtb/files/CMakeLists.txt
+++ b/sci-mathematics/diagrtb/files/CMakeLists.txt
@@ -6,7 +6,6 @@ option (EXAMPLES "Instal additional example files" OFF)
add_executable(diagrtb diagrtb.f)
install (TARGETS diagrtb DESTINATION bin)
-install (FILES diagrtb.README DESTINATION share/doc/diagrtb)
if ( EXAMPLES )
install (DIRECTORY ../Try_RTB2011 DESTINATION share/diagrtb/examples)