summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/flint')
-rw-r--r--sci-mathematics/flint/flint-2.4.4-r1.ebuild6
-rw-r--r--sci-mathematics/flint/flint-2.4.5.ebuild6
-rw-r--r--sci-mathematics/flint/flint-2.5.2.ebuild8
3 files changed, 17 insertions, 3 deletions
diff --git a/sci-mathematics/flint/flint-2.4.4-r1.ebuild b/sci-mathematics/flint/flint-2.4.4-r1.ebuild
index 8e4d583bd035..aca6c9be9410 100644
--- a/sci-mathematics/flint/flint-2.4.4-r1.ebuild
+++ b/sci-mathematics/flint/flint-2.4.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -31,6 +31,10 @@ src_prepare() {
"${FILESDIR}"/${PN}-2.4.3-whitespaces.patch \
"${FILESDIR}"/${PN}-2.4.3-cflags-ldflags.patch \
"${FILESDIR}"/${PN}-2.4.4-test.patch
+
+ sed -i \
+ -e '/echo "DLPATH_ADD=/s/\$DLPATH_ADD/\\\$(CURDIR)/' \
+ ./configure || die
}
src_configure() {
diff --git a/sci-mathematics/flint/flint-2.4.5.ebuild b/sci-mathematics/flint/flint-2.4.5.ebuild
index 318603218d17..a8293b9632a7 100644
--- a/sci-mathematics/flint/flint-2.4.5.ebuild
+++ b/sci-mathematics/flint/flint-2.4.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -33,6 +33,10 @@ src_prepare() {
"${FILESDIR}"/${PN}-2.4.4-test.patch \
"${FILESDIR}"/${PN}-2.4.5-gmp6-compat.patch \
"${FILESDIR}"/${PN}-2.4.5-ntl62.patch
+
+ sed -i \
+ -e '/echo "DLPATH_ADD=/s/\$DLPATH_ADD/\\\$(CURDIR)/' \
+ ./configure || die
}
src_configure() {
diff --git a/sci-mathematics/flint/flint-2.5.2.ebuild b/sci-mathematics/flint/flint-2.5.2.ebuild
index e7ccd5124387..0217ae0600ca 100644
--- a/sci-mathematics/flint/flint-2.5.2.ebuild
+++ b/sci-mathematics/flint/flint-2.5.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -26,6 +26,12 @@ DEPEND="${RDEPEND}
dev-texlive/texlive-latexextra
)"
+src_prepare() {
+ sed -i \
+ -e '/echo "DLPATH_ADD=/s/\$DLPATH_ADD/\\\$(CURDIR)/' \
+ ./configure || die
+}
+
src_configure() {
./configure \
--prefix="${EPREFIX}/usr" \