summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/lybniz/lybniz-1.3.2.ebuild')
-rw-r--r--sci-mathematics/lybniz/lybniz-1.3.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-mathematics/lybniz/lybniz-1.3.2.ebuild b/sci-mathematics/lybniz/lybniz-1.3.2.ebuild
new file mode 100644
index 000000000000..092755bd3a56
--- /dev/null
+++ b/sci-mathematics/lybniz/lybniz-1.3.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit distutils
+
+DESCRIPTION="A function plotter program written in PyGTK"
+HOMEPAGE="http://lybniz2.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lybniz2/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/pygtk:2"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ sed -i \
+ -e 's/Education;/Education;Math;/' \
+ ${PN}.desktop || die
+}