summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/nestedsums')
-rw-r--r--sci-mathematics/nestedsums/Manifest1
-rw-r--r--sci-mathematics/nestedsums/nestedsums-1.4.12-r2.ebuild (renamed from sci-mathematics/nestedsums/nestedsums-1.4.12-r1.ebuild)4
-rw-r--r--sci-mathematics/nestedsums/nestedsums-1.5.1.ebuild41
3 files changed, 44 insertions, 2 deletions
diff --git a/sci-mathematics/nestedsums/Manifest b/sci-mathematics/nestedsums/Manifest
index 02634325f5da..279cb0924580 100644
--- a/sci-mathematics/nestedsums/Manifest
+++ b/sci-mathematics/nestedsums/Manifest
@@ -1 +1,2 @@
DIST nestedsums-1.4.12.tar.gz 415265 SHA256 4d290529373e83d205d9fe2d1ff1d9f2f95b3dd1dba1585d298ba52593ce831c SHA512 2fbda746655958f34d83f61779fa7036152a75a8b90423d039ce8693b59fcec3794e1898759c2ee64c4751a745f9f2a910be607b1d656fcc32c093a9cfe4bd4e WHIRLPOOL 60ee37d78731739e05bc49010ad904d2258ddd1b8d3ae6f4ad1a3c50b5d077255b76202309a1d7d84185ff059e11615d72b39bad8f5ec9b139bc946b5e6e013f
+DIST nestedsums-1.5.1.tar.gz 511814 SHA256 a68446ab86cc4e6cccda90ba9cd7180c8394639b89d2e2d4d9cfd1684e023545 SHA512 e68e6b58125c5049aebe8d3769b92b7af7c40ea1bcf2caac5091a4c79015c51793d0c78dae20e01d05bdaac9106d54c8a59f6b2157ea6d497cfd117008127aa2 WHIRLPOOL 465dd3e4fdfdb1fc636f7f118057338b668a09965a89497fdd2666961eb74bfb4d87cf66d6bc88aade541516d8001fd63b501b58a6ad59b71ae9f5d4eec2284f
diff --git a/sci-mathematics/nestedsums/nestedsums-1.4.12-r1.ebuild b/sci-mathematics/nestedsums/nestedsums-1.4.12-r2.ebuild
index b1d8c56fb805..327eff70d67a 100644
--- a/sci-mathematics/nestedsums/nestedsums-1.4.12-r1.ebuild
+++ b/sci-mathematics/nestedsums/nestedsums-1.4.12-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="3"
@@ -9,7 +9,7 @@ SRC_URI="http://wwwthep.physik.uni-mainz.de/~stefanw/download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RDEPEND=">=sci-mathematics/ginac-1.5"
+RDEPEND=">=sci-mathematics/ginac-1.5 <sci-mathematics/ginac-1.7"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
diff --git a/sci-mathematics/nestedsums/nestedsums-1.5.1.ebuild b/sci-mathematics/nestedsums/nestedsums-1.5.1.ebuild
new file mode 100644
index 000000000000..80fa329a76ce
--- /dev/null
+++ b/sci-mathematics/nestedsums/nestedsums-1.5.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic
+
+DESCRIPTION="A GiNaC-based library for symbolic expansion of certain transcendental functions"
+HOMEPAGE="http://wwwthep.physik.uni-mainz.de/~stefanw/nestedsums/"
+IUSE="doc"
+SRC_URI="http://wwwthep.physik.uni-mainz.de/~stefanw/download/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RDEPEND=">=sci-mathematics/ginac-1.7"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ append-cxxflags -std=c++11
+ default
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ doxygen Doxyfile || die "generating documentation failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ rm -f "${D}"usr/lib/*.la
+ dodoc AUTHORS ChangeLog
+
+ if use doc; then
+ dohtml reference/html/*
+ fi
+}