summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/sha1-polyml/sha1-polyml-5.5.0.ebuild')
-rw-r--r--sci-mathematics/sha1-polyml/sha1-polyml-5.5.0.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/sci-mathematics/sha1-polyml/sha1-polyml-5.5.0.ebuild b/sci-mathematics/sha1-polyml/sha1-polyml-5.5.0.ebuild
index b8150e07cd2b..a5d68567de68 100644
--- a/sci-mathematics/sha1-polyml/sha1-polyml-5.5.0.ebuild
+++ b/sci-mathematics/sha1-polyml/sha1-polyml-5.5.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -60,9 +60,11 @@ src_prepare() {
}
src_compile() {
- arch=$(uname -m)
- uos=$(uname)
- los=${uos,,}
+ local arch=$(uname -m)
+ local uos=$(uname)
+ # Switch to ,, when we switch to EAPI=6.
+ #local los=${uos,,}
+ local los=$(tr '[:upper:]' '[:lower:]' <<<"${uos}")
./build "${arch}-${los}" || die "build failed"
}