summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/why3-for-spark/metadata.xml1
-rw-r--r--sci-mathematics/why3-for-spark/why3-for-spark-2017.ebuild8
2 files changed, 6 insertions, 3 deletions
diff --git a/sci-mathematics/why3-for-spark/metadata.xml b/sci-mathematics/why3-for-spark/metadata.xml
index f73ffa40b698..dfc2bea31bd5 100644
--- a/sci-mathematics/why3-for-spark/metadata.xml
+++ b/sci-mathematics/why3-for-spark/metadata.xml
@@ -23,5 +23,6 @@
<flag name="hypothesis-selection">Enable hypothesis selection</flag>
<flag name="profiling">Enable profiling</flag>
<flag name="zarith">Use <pkg>dev-ml/zarith</pkg></flag>
+ <flag name="zip">Enable compression of session files</flag>
</use>
</pkgmetadata>
diff --git a/sci-mathematics/why3-for-spark/why3-for-spark-2017.ebuild b/sci-mathematics/why3-for-spark/why3-for-spark-2017.ebuild
index 596bdfc7fe14..0216951fd816 100644
--- a/sci-mathematics/why3-for-spark/why3-for-spark-2017.ebuild
+++ b/sci-mathematics/why3-for-spark/why3-for-spark-2017.ebuild
@@ -15,7 +15,7 @@ SRC_URI="http://mirrors.cdn.adacore.com/art/591c45e2c7a447af2deed055
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="coq doc emacs gtk html hypothesis-selection profiling zarith"
+IUSE="coq doc emacs gtk html hypothesis-selection profiling zarith zip"
DEPEND=">=dev-lang/ocaml-4.02.3
dev-ml/menhir
@@ -25,7 +25,8 @@ DEPEND=">=dev-lang/ocaml-4.02.3
emacs? ( app-editors/emacs:* )
html? ( dev-tex/hevea )
hypothesis-selection? ( dev-ml/ocamlgraph )
- zarith? ( dev-ml/zarith )"
+ zarith? ( dev-ml/zarith )
+ zip? ( dev-ml/camlzip )"
RDEPEND="${DEPEND}"
S="${WORKDIR}"/${MYP}
@@ -56,7 +57,8 @@ src_configure() {
$(use_enable html html-doc) \
$(use_enable hypothesis-selection) \
$(use_enable profiling) \
- $(use_enable zarith)
+ $(use_enable zarith) \
+ $(use_enable zip)
}
src_compile() {