summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/fann/fann-2.2.0-r1.ebuild10
-rw-r--r--sci-mathematics/fann/fann-9999.ebuild8
2 files changed, 9 insertions, 9 deletions
diff --git a/sci-mathematics/fann/fann-2.2.0-r1.ebuild b/sci-mathematics/fann/fann-2.2.0-r1.ebuild
index f37ab14a8884..044956a1bb4e 100644
--- a/sci-mathematics/fann/fann-2.2.0-r1.ebuild
+++ b/sci-mathematics/fann/fann-2.2.0-r1.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
MY_P=FANN-${PV}-Source
-inherit cmake-multilib
+inherit cmake
DESCRIPTION="Fast Artificial Neural Network Library"
-HOMEPAGE="http://leenissen.dk/fann/"
+HOMEPAGE="http://leenissen.dk/fann/wp/"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
LICENSE="LGPL-2.1"
@@ -16,7 +16,7 @@ KEYWORDS="~amd64 ~ppc ~x86"
IUSE="examples"
RDEPEND=""
-DEPEND="app-arch/unzip"
+BDEPEND="app-arch/unzip"
S="${WORKDIR}/${MY_P}"
@@ -30,7 +30,7 @@ src_test() {
}
src_install() {
- cmake-multilib_src_install
+ cmake_src_install
if use examples; then
insinto /usr/share/doc/${PF}
doins -r examples
diff --git a/sci-mathematics/fann/fann-9999.ebuild b/sci-mathematics/fann/fann-9999.ebuild
index 6ac50e2ce43f..b9c40c483009 100644
--- a/sci-mathematics/fann/fann-9999.ebuild
+++ b/sci-mathematics/fann/fann-9999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-multilib git-r3 toolchain-funcs
+inherit cmake git-r3 toolchain-funcs
DESCRIPTION="Fast Artificial Neural Network Library"
-HOMEPAGE="http://leenissen.dk/fann/"
+HOMEPAGE="http://leenissen.dk/fann/wp/"
EGIT_REPO_URI="https://github.com/libfann/fann"
LICENSE="LGPL-2.1"
@@ -20,7 +20,7 @@ src_test() {
}
src_install() {
- cmake-multilib_src_install
+ cmake_src_install
if use examples; then
insinto /usr/share/doc/${PF}
doins -r examples