summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/why3-for-spark/Manifest1
-rw-r--r--sci-mathematics/why3-for-spark/files/why3-for-spark-2018-gentoo.patch25
-rw-r--r--sci-mathematics/why3-for-spark/why3-for-spark-2018.ebuild75
3 files changed, 101 insertions, 0 deletions
diff --git a/sci-mathematics/why3-for-spark/Manifest b/sci-mathematics/why3-for-spark/Manifest
index dfdecc5d6241..e6505ed60c75 100644
--- a/sci-mathematics/why3-for-spark/Manifest
+++ b/sci-mathematics/why3-for-spark/Manifest
@@ -1 +1,2 @@
DIST why3-for-spark-gpl-2017-src.tar.gz 9248235 BLAKE2B d9eb7201dfd5962c88ac8995e3cd800bf318f575a5e6ff7d0219941c0f0c9052e6b2c95c7c16fcd81b90cac647d503041bf16560bd44b58e7e0ced1ef2314bd2 SHA512 8f444402f6c1744cd7c565117732935791b1ae7996a94314c40a66d125eae8a81f2257314246c94fd29d3cd16abcff6a50a152a1191a4aae39a2c8a8d7c3b9e1
+DIST why3-for-spark-gpl-2018-src.tar.gz 7682767 BLAKE2B 0b0272ca4d5519ca402990b234d0847378bcd2a0949fea78ea10e355233a16aebe79b938cdf8e4daadabb909171cab83b9d6ccacf9f2dc1c0b57bb6da6fd1fe0 SHA512 fc798acf343484fd8e70f470a318753c9a0e9967ff579f20ec185bf3c2a75e7a4a556388fc86a378610ce4a467f3e722c6f610da34d4c33bc3d6b10551731f07
diff --git a/sci-mathematics/why3-for-spark/files/why3-for-spark-2018-gentoo.patch b/sci-mathematics/why3-for-spark/files/why3-for-spark-2018-gentoo.patch
new file mode 100644
index 000000000000..9d7165cbed78
--- /dev/null
+++ b/sci-mathematics/why3-for-spark/files/why3-for-spark-2018-gentoo.patch
@@ -0,0 +1,25 @@
+--- why3-for-spark-gpl-2017-src/src/gnat/gnat_config.ml.old 2017-10-18 09:07:03.118919785 +0200
++++ why3-for-spark-gpl-2017-src/src/gnat/gnat_config.ml 2017-10-18 09:07:45.198216939 +0200
+@@ -12,10 +12,7 @@
+ | Limit_Check of Gnat_expl.check
+ | Limit_Line of Gnat_loc.loc
+
+-let spark_prefix =
+- (Filename.dirname
+- (Filename.dirname (Filename.dirname
+- (Filename.dirname Sys.executable_name))))
++let spark_prefix = "/usr"
+
+ let rec file_concat l =
+ match l with
+--- why3-for-spark-gpl-2017-src/src/coq-tactic/why3tac.ml4.old 2017-10-26 22:25:55.289094778 +0200
++++ why3-for-spark-gpl-2017-src/src/coq-tactic/why3tac.ml4 2017-10-26 22:26:10.719807270 +0200
+@@ -1352,7 +1352,7 @@
+ let limit =
+ { Call_provers.empty_limit with Call_provers.limit_time = timelimit } in
+ let call = Driver.prove_task ~command ~limit drv !task in
+- wait_on_call call
++ wait_on_call (ServerCall call)
+ with
+ | NotFO ->
+ if debug then Printexc.print_backtrace stderr; flush stderr;
diff --git a/sci-mathematics/why3-for-spark/why3-for-spark-2018.ebuild b/sci-mathematics/why3-for-spark/why3-for-spark-2018.ebuild
new file mode 100644
index 000000000000..e766cce4ade3
--- /dev/null
+++ b/sci-mathematics/why3-for-spark/why3-for-spark-2018.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+MYP=${PN}-gpl-${PV}-src
+
+DESCRIPTION="Platform for deductive program verification"
+HOMEPAGE="http://why3.lri.fr/"
+SRC_URI="http://mirrors.cdn.adacore.com/art/5b0819dec7a447df26c27a43
+ -> ${MYP}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="coq doc emacs gtk html hypothesis-selection +ocamlopt profiling zarith zip"
+RESTRICT=strip
+
+DEPEND=">=dev-lang/ocaml-4.02.3[ocamlopt?]
+ dev-ml/menhir
+ coq? ( sci-mathematics/coq )
+ doc? ( dev-tex/rubber )
+ gtk? ( dev-ml/lablgtk[sourceview] )
+ emacs? ( app-editors/emacs:* )
+ html? ( dev-tex/hevea )
+ hypothesis-selection? ( dev-ml/ocamlgraph )
+ zarith? ( dev-ml/zarith )
+ zip? ( >=dev-ml/camlzip-1.07 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MYP}
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+REQUIRED_USE="html? ( doc )"
+
+src_configure() {
+ econf \
+ --disable-pvs-libs \
+ --disable-isabelle-libs \
+ $(use_enable coq coq-libs) \
+ $(use_enable coq coq-tactic) \
+ $(use_enable doc) \
+ $(use_enable emacs emacs-compilation) \
+ $(use_enable gtk ide) \
+ $(use_enable html html-doc) \
+ $(use_enable hypothesis-selection) \
+ $(use_enable ocamlopt native-code) \
+ $(use_enable profiling) \
+ $(use_enable zarith) \
+ $(use_enable zip)
+}
+
+src_compile() {
+ emake -j1
+ if use ocamlopt; then
+ emake byte
+ fi
+ use doc && emake doc
+}
+
+src_install() {
+ emake DESTDIR="${D}" -j1 install
+ emake DESTDIR="${D}" -j1 install-lib
+ emake DESTDIR="${D}" install_spark2014_dev
+ einstalldocs
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ if use doc; then
+ dodoc doc/manual.pdf
+ use html && dodoc -r doc/html
+ fi
+}