summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/cliquer/Manifest1
-rw-r--r--sci-mathematics/cliquer/cliquer-1.21.ebuild29
-rw-r--r--sci-mathematics/cliquer/metadata.xml24
3 files changed, 54 insertions, 0 deletions
diff --git a/sci-mathematics/cliquer/Manifest b/sci-mathematics/cliquer/Manifest
new file mode 100644
index 000000000000..587ee4b6b0e4
--- /dev/null
+++ b/sci-mathematics/cliquer/Manifest
@@ -0,0 +1 @@
+DIST cliquer-1.21.tar.gz 412440 BLAKE2B 0a4f31f6b005822271c67ab2f2532809b112a5ceb7aaf828b06bf6ca4cadfb836d3c1f6b70187908104c2eefedeececad6b020cde2d198141dc69801d5b1ce81 SHA512 2f72a649cfef46ef07cc3817a704fbfcda910b0b0a419deb361b2aa18437e4689a8b965e0e364a5d9ae391ba8591e022a0dc414b21c9102094ad28fb2f1b15a8
diff --git a/sci-mathematics/cliquer/cliquer-1.21.ebuild b/sci-mathematics/cliquer/cliquer-1.21.ebuild
new file mode 100644
index 000000000000..e1d639781d68
--- /dev/null
+++ b/sci-mathematics/cliquer/cliquer-1.21.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="C routines for finding cliques in an arbitrary weighted graph"
+
+# autocliquer is a fork of cliquer (whose last release was in 2010) by
+# one of the SageMath developers with an autotools build system.
+HOMEPAGE="https://users.aalto.fi/~pat/cliquer.html
+ https://github.com/dimpase/autocliquer"
+
+# The github tarball doesn't contain the generated autotools files (like
+# the ./configure script).
+SRC_URI="http://files.sagemath.org/spkg/upstream/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+src_configure(){
+ econf $(use_enable static-libs static)
+}
+
+src_install(){
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/sci-mathematics/cliquer/metadata.xml b/sci-mathematics/cliquer/metadata.xml
new file mode 100644
index 000000000000..94aafb3a9ea9
--- /dev/null
+++ b/sci-mathematics/cliquer/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <!--
+ mjo: François maintained this package in the sage-on-gentoo overlay
+ long before I moved it into ::gentoo. You don't need an ACK from me
+ to merge his changes.
+ -->
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+
+ <upstream>
+ <remote-id type="github">dimpase/autocliquer</remote-id>
+ </upstream>
+</pkgmetadata>