summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/boinc/boinc-7.6.31-r3.ebuild (renamed from sci-misc/boinc/boinc-7.6.31-r2.ebuild)34
1 files changed, 13 insertions, 21 deletions
diff --git a/sci-misc/boinc/boinc-7.6.31-r2.ebuild b/sci-misc/boinc/boinc-7.6.31-r3.ebuild
index f1c24082dbef..6e2e785acef9 100644
--- a/sci-misc/boinc/boinc-7.6.31-r2.ebuild
+++ b/sci-misc/boinc/boinc-7.6.31-r3.ebuild
@@ -50,32 +50,24 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${PN}-client_release-${MY_PV}-${PV}"
pkg_setup() {
+ # Bug 578750
if use kernel_linux; then
linux-info_pkg_setup
if ! linux_config_exists; then
ewarn "Can't check the linux kernel configuration."
ewarn "You might be missing vsyscall support."
- else
- if kernel_is -ge 4 4 \
- && linux_chkconfig_present LEGACY_VSYSCALL_NONE \
- && ! linux_chkconfig_present X86_VSYSCALL_EMULATION; then
- ewarn "You do have neither x86 vsyscall emulation"
- ewarn "nor legacy vsyscall support enabled."
- ewarn "This will prevent some boinc projects from running."
- ewarn "Please enable vsyscall emulation:"
- ewarn " CONFIG_X86_VSYSCALL_EMULATION=y"
- ewarn "in /usr/src/linux/.config, to be found at"
- ewarn " Processor type and features --->"
- ewarn " [*] Enable vsyscall emulation"
- ewarn "or set"
- ewarn " CONFIG_LEGACY_VSYSCALL_EMULATE=y"
- ewarn "in /usr/src/linux/.config, to be found at"
- ewarn " Processor type and features --->"
- ewarn " vsyscall table for legacy applications (None) --->"
- ewarn " (X) Emulate"
- ewarn "Alternatively, you can enable CONFIG_LEGACY_VSYSCALL_NATIVE."
- ewarn "However, this has security implications and is not recommended."
- fi
+ elif kernel_is -ge 4 4 \
+ && linux_chkconfig_present LEGACY_VSYSCALL_NONE; then
+ ewarn "You do not have vsyscall emulation enabled."
+ ewarn "This will prevent some boinc projects from running."
+ ewarn "Please enable vsyscall emulation:"
+ ewarn " CONFIG_LEGACY_VSYSCALL_EMULATE=y"
+ ewarn "in /usr/src/linux/.config, to be found at"
+ ewarn " Processor type and features --->"
+ ewarn " vsyscall table for legacy applications (None) --->"
+ ewarn " (X) Emulate"
+ ewarn "Alternatively, you can enable CONFIG_LEGACY_VSYSCALL_NATIVE."
+ ewarn "However, this has security implications and is not recommended."
fi
fi
}