summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/geant4_vmc/geant4_vmc-9999.ebuild')
-rw-r--r--sci-physics/geant4_vmc/geant4_vmc-9999.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/sci-physics/geant4_vmc/geant4_vmc-9999.ebuild b/sci-physics/geant4_vmc/geant4_vmc-9999.ebuild
index 2bc5b7595a6d..988ae63d16b7 100644
--- a/sci-physics/geant4_vmc/geant4_vmc-9999.ebuild
+++ b/sci-physics/geant4_vmc/geant4_vmc-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake
+inherit cmake virtualx
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -23,12 +23,12 @@ SLOT="4"
IUSE="doc examples geant3 +g4root vgm test"
RDEPEND="
- sci-physics/geant[c++17,opengl,geant3?]
+ sci-physics/geant:=[c++17,opengl,geant3?]
sci-physics/root:=[c++17,-vmc(-)]
sci-physics/vmc:=[c++17]
vgm? ( sci-physics/vgm:= )"
DEPEND="${RDEPEND}
- test? ( >=sci-physics/geant-4.11[gdml] )"
+ test? ( sci-physics/geant:=[gdml] )"
BDEPEND="doc? ( app-doc/doxygen[dot] )"
RESTRICT="
!examples? ( test )
@@ -68,8 +68,8 @@ src_compile() {
src_test() {
cd examples || die
- ./test_suite.sh --debug --g3=off --garfield=off --builddir="${BUILD_DIR}" || die
- ./test_suite_exe.sh --g3=off --garfield=off --garfield=off --builddir="${BUILD_DIR}" || die
+ virtx ./test_suite.sh --debug --g3=off --garfield=off --builddir="${BUILD_DIR}" || die
+ virtx ./test_suite_exe.sh --g3=off --garfield=off --garfield=off --builddir="${BUILD_DIR}" || die
}
src_install() {