summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/root/root-6.02.05-r2.ebuild18
-rw-r--r--sci-physics/root/root-6.04.06.ebuild17
2 files changed, 35 insertions, 0 deletions
diff --git a/sci-physics/root/root-6.02.05-r2.ebuild b/sci-physics/root/root-6.02.05-r2.ebuild
index 5bb87419d91a..a410d12296b9 100644
--- a/sci-physics/root/root-6.02.05-r2.ebuild
+++ b/sci-physics/root/root-6.02.05-r2.ebuild
@@ -140,6 +140,24 @@ check_compiler() {
;;
*g++*)
ver="$(gcc-version)"
+ # gcc-5 is not yet supported, bug 564306
+ if version_is_at_least "5" "${ver}"; then
+ eerror ""
+ eerror "GCC-5 is not yet supported in ROOT-6."
+ eerror "The code may build for you, but will have run-time failures."
+ eerror "See the following bugs:"
+ eerror "https://sft.its.cern.ch/jira/browse/ROOT-7285"
+ eerror "https://sft.its.cern.ch/jira/browse/ROOT-7319"
+ eerror "https://sft.its.cern.ch/jira/browse/ROOT-7654"
+ eerror "https://sft.its.cern.ch/jira/browse/ROOT-7721"
+ eerror "https://sft.its.cern.ch/jira/browse/ROOT-7818"
+ eerror "https://sft.its.cern.ch/jira/browse/ROOT-7895"
+ eerror "https://bugs.gentoo.org/show_bug.cgi?id=564306"
+ eerror ""
+ eerror "Please use GCC-4.9 for now."
+ eerror ""
+ die "gcc-5 is not yet supported"
+ fi
cur="$2"
;;
*icc*|*icpc*)
diff --git a/sci-physics/root/root-6.04.06.ebuild b/sci-physics/root/root-6.04.06.ebuild
index 093ad9ff55c9..c3ef6fb100cd 100644
--- a/sci-physics/root/root-6.04.06.ebuild
+++ b/sci-physics/root/root-6.04.06.ebuild
@@ -135,6 +135,23 @@ check_compiler() {
;;
*g++*)
ver="$(gcc-version)"
+ if version_is_at_least "5" "${ver}"; then
+ eerror ""
+ eerror "GCC-5 is not yet supported in ROOT-6."
+ eerror "The code may build for you, but will have run-time failures."
+ eerror "See the following bugs:"
+ eerror "https://sft.its.cern.ch/jira/browse/ROOT-7285"
+ eerror "https://sft.its.cern.ch/jira/browse/ROOT-7319"
+ eerror "https://sft.its.cern.ch/jira/browse/ROOT-7654"
+ eerror "https://sft.its.cern.ch/jira/browse/ROOT-7721"
+ eerror "https://sft.its.cern.ch/jira/browse/ROOT-7818"
+ eerror "https://sft.its.cern.ch/jira/browse/ROOT-7895"
+ eerror "https://bugs.gentoo.org/show_bug.cgi?id=564306"
+ eerror ""
+ eerror "Please use GCC-4.9 for now."
+ eerror ""
+ die "gcc-5 is not yet supported"
+ fi
cur="$2"
;;
*icc*|*icpc*)