summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-visualization/gnuplot/files')
-rw-r--r--sci-visualization/gnuplot/files/gnuplot-5.0.1-fix-underlinking.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/sci-visualization/gnuplot/files/gnuplot-5.0.1-fix-underlinking.patch b/sci-visualization/gnuplot/files/gnuplot-5.0.1-fix-underlinking.patch
new file mode 100644
index 000000000000..c39bc828f268
--- /dev/null
+++ b/sci-visualization/gnuplot/files/gnuplot-5.0.1-fix-underlinking.patch
@@ -0,0 +1,17 @@
+Description: Add missing linkage against X11 libs.
+Author: Anton Gladky <gladk@debian.org>
+Last-Update: 2015-06-16
+
+Index: gnuplot-5.0.1/src/Makefile.am
+===================================================================
+--- gnuplot-5.0.1.orig/src/Makefile.am
++++ gnuplot-5.0.1/src/Makefile.am
+@@ -89,6 +89,8 @@ $(EXTRA_gnuplot_SOURCES)
+
+ if BUILD_WXWIDGETS
+ gnuplot_SOURCES += wxterminal/wxt_gui.cpp
++XLIBS = @LIBRARIES_FOR_X@
++gnuplot_LDADD += $(XLIBS)
+ endif
+
+ if BUILD_GPCAIRO