summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sec-keys')
-rw-r--r--sec-keys/openpgp-keys-apache-xmlgraphics-batik/Manifest1
-rw-r--r--sec-keys/openpgp-keys-apache-xmlgraphics-batik/metadata.xml8
-rw-r--r--sec-keys/openpgp-keys-apache-xmlgraphics-batik/openpgp-keys-apache-xmlgraphics-batik-20170410.ebuild20
3 files changed, 29 insertions, 0 deletions
diff --git a/sec-keys/openpgp-keys-apache-xmlgraphics-batik/Manifest b/sec-keys/openpgp-keys-apache-xmlgraphics-batik/Manifest
new file mode 100644
index 000000000000..6b6c85d28590
--- /dev/null
+++ b/sec-keys/openpgp-keys-apache-xmlgraphics-batik/Manifest
@@ -0,0 +1 @@
+DIST openpgp-keys-apache-xmlgraphics-batik-20170410-KEYS.asc 18450 BLAKE2B 160f9fb04c0b349b59b50c5fcc811ac087407be682f114b2f32c7747f7b1c46d0def6fe27aa3b79ef1b8e35cdcece8cc3761a89ec00b8575b8919944173c79d5 SHA512 98c2d7e51c76c64c9c0040bd18851d08cb55f383d7850a01bcd7df3e0b5eb123e23bf064e10d58d72d627edfa118f1c12bb814e71be5255834274179b90fdc6b
diff --git a/sec-keys/openpgp-keys-apache-xmlgraphics-batik/metadata.xml b/sec-keys/openpgp-keys-apache-xmlgraphics-batik/metadata.xml
new file mode 100644
index 000000000000..6ef2d50cf07e
--- /dev/null
+++ b/sec-keys/openpgp-keys-apache-xmlgraphics-batik/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sec-keys/openpgp-keys-apache-xmlgraphics-batik/openpgp-keys-apache-xmlgraphics-batik-20170410.ebuild b/sec-keys/openpgp-keys-apache-xmlgraphics-batik/openpgp-keys-apache-xmlgraphics-batik-20170410.ebuild
new file mode 100644
index 000000000000..bc986dd43e67
--- /dev/null
+++ b/sec-keys/openpgp-keys-apache-xmlgraphics-batik/openpgp-keys-apache-xmlgraphics-batik-20170410.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="OpenPGP keys used by xmlgraphics.apache.org/batik"
+HOMEPAGE="https://xmlgraphics.apache.org/batik/download.html"
+SRC_URI="https://downloads.apache.org/xmlgraphics/batik/KEYS -> ${P}-KEYS.asc"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ppc64 x86"
+
+S="${WORKDIR}"
+
+src_install() {
+ local files=( ${A} )
+ insinto /usr/share/openpgp-keys
+ newins - xmlgraphics-batik.apache.org.asc < <(cat "${files[@]/#/${DISTDIR}/}" || die)
+}