summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/accountsservice/accountsservice-0.6.50-r1.ebuild')
-rw-r--r--sys-apps/accountsservice/accountsservice-0.6.50-r1.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/sys-apps/accountsservice/accountsservice-0.6.50-r1.ebuild b/sys-apps/accountsservice/accountsservice-0.6.50-r1.ebuild
deleted file mode 100644
index 11a90ec3611e..000000000000
--- a/sys-apps/accountsservice/accountsservice-0.6.50-r1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-GNOME2_EAUTORECONF="yes"
-
-inherit gnome2 systemd
-
-DESCRIPTION="D-Bus interfaces for querying and manipulating user account information"
-HOMEPAGE="https://www.freedesktop.org/wiki/Software/AccountsService/"
-SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ppc ppc64 ~sparc x86"
-
-IUSE="doc elogind +introspection selinux systemd"
-REQUIRED_USE="^^ ( elogind systemd )"
-
-CDEPEND="
- >=dev-libs/glib-2.44:2
- sys-auth/polkit
- elogind? ( >=sys-auth/elogind-229.4 )
- introspection? ( >=dev-libs/gobject-introspection-0.9.12:= )
- systemd? ( >=sys-apps/systemd-186:0= )
-"
-DEPEND="${CDEPEND}
- dev-libs/libxslt
- dev-util/gdbus-codegen
- >=dev-util/gtk-doc-am-1.15
- >=dev-util/intltool-0.40
- sys-devel/gettext
- virtual/pkgconfig
- doc? (
- app-text/docbook-xml-dtd:4.1.2
- app-text/xmlto )
-"
-RDEPEND="${CDEPEND}
- selinux? ( sec-policy/selinux-accountsd )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.6.35-gentoo-system-users.patch
-
- # lib: don't set loaded state until seat is fetched (from 'master')
- "${FILESDIR}"/${P}-loaded-state.patch
-)
-
-src_configure() {
- gnome2_src_configure \
- --disable-static \
- --disable-more-warnings \
- --localstatedir="${EPREFIX}"/var \
- --enable-admin-group="wheel" \
- --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
- $(use_enable doc docbook-docs) \
- $(use_enable elogind) \
- $(use_enable introspection) \
- $(use_enable systemd)
-}