summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/biosdisk')
-rw-r--r--sys-apps/biosdisk/Manifest1
-rw-r--r--sys-apps/biosdisk/biosdisk-0_p20171116.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/biosdisk/Manifest b/sys-apps/biosdisk/Manifest
index 46ed32780573..78d9f22fb755 100644
--- a/sys-apps/biosdisk/Manifest
+++ b/sys-apps/biosdisk/Manifest
@@ -1 +1,2 @@
+DIST biosdisk-0_p20171116.tar.gz 712587 BLAKE2B f09a8c68f57cddb1949d369cfc18d1216c3e64612a7074c58e6c50c12682fce92a4d6295810d5358fac0340483387f14059811a5681ae4f37c7da8e40c34fec4 SHA512 27d99990d0e92f1295d2ddb949214946db681e7f80c6606b252473fe7b5b0d3254180b54cb26479c9014219f6b989aa6ba29e8a818f3801f9ccce4efd2f1c3b9
DIST biosdisk-git-06112010.tar.gz 1195889 BLAKE2B 7363402fea58e5709517ec2bc30865b352fa55472a8f4688f371f6080d850ba358f30d6c524a32f0f9df9a82092202814698e3452f4e9862a8f31349a8a3d545 SHA512 ade60e0e1ebb069e7f8d2046eff479cdb5186e54e0408b7fe65ac803476c9e325f9771617bbbcd60471d6b2d637aaef20c68af89c16c4ea26e04cfe501e4a310
diff --git a/sys-apps/biosdisk/biosdisk-0_p20171116.ebuild b/sys-apps/biosdisk/biosdisk-0_p20171116.ebuild
new file mode 100644
index 000000000000..87367d63b19d
--- /dev/null
+++ b/sys-apps/biosdisk/biosdisk-0_p20171116.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+EGIT_COMMIT="f534dd22a795dca9c42f44b52f206bf02eadb682"
+DESCRIPTION="A script that creates floppy boot images to flash Dell BIOSes"
+HOMEPAGE="https://github.com/dell/biosdisk"
+SRC_URI="https://github.com/dell/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ >=app-text/dos2unix-5.0
+ sys-boot/syslinux
+ ${PYTHON_DEPS}
+"
+
+S=${WORKDIR}/${PN}-${EGIT_COMMIT}
+
+src_install() {
+ python_fix_shebang blconf
+
+ dosbin biosdisk blconf
+
+ dodoc AUTHORS README README.dosdisk TODO VERSION
+ gunzip biosdisk.8.gz || die
+ doman biosdisk.8
+
+ insinto /usr/share/biosdisk
+ doins dosdisk.img dosdisk{288,8192,20480}.img biosdisk-mkrpm-{fedora,redhat,generic}-template.spec
+
+ insinto /etc
+ doins biosdisk.conf
+}