summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/busybox/busybox-9999.ebuild')
-rw-r--r--sys-apps/busybox/busybox-9999.ebuild164
1 files changed, 104 insertions, 60 deletions
diff --git a/sys-apps/busybox/busybox-9999.ebuild b/sys-apps/busybox/busybox-9999.ebuild
index bf29c9fb1d87..74082ac77ae5 100644
--- a/sys-apps/busybox/busybox-9999.ebuild
+++ b/sys-apps/busybox/busybox-9999.ebuild
@@ -1,39 +1,51 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# See `man savedconfig.eclass` for info on how to use USE=savedconfig.
-EAPI=6
+EAPI=8
-inherit flag-o-matic savedconfig toolchain-funcs
+inherit flag-o-matic readme.gentoo-r1 savedconfig toolchain-funcs
DESCRIPTION="Utilities for rescue and embedded systems"
HOMEPAGE="https://www.busybox.net/"
if [[ ${PV} == "9999" ]] ; then
- MY_P=${P}
+ MY_P="${P}"
EGIT_REPO_URI="https://git.busybox.net/busybox"
inherit git-r3
else
- MY_P=${PN}-${PV/_/-}
+ MY_P="${PN}-${PV/_/-}"
SRC_URI="https://www.busybox.net/downloads/${MY_P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
fi
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2" # GPL-2 only
SLOT="0"
-IUSE="debug ipv6 livecd make-symlinks math mdev pam selinux sep-usr static syslog systemd"
+IUSE="debug livecd make-symlinks math mdev pam selinux sep-usr static syslog systemd"
REQUIRED_USE="pam? ( !static )"
RESTRICT="test"
-COMMON_DEPEND="!static? ( selinux? ( sys-libs/libselinux ) )
- pam? ( sys-libs/pam )"
-DEPEND="${COMMON_DEPEND}
- static? ( selinux? ( sys-libs/libselinux[static-libs(+)] ) )
- >=sys-kernel/linux-headers-2.6.39"
-RDEPEND="${COMMON_DEPEND}
- mdev? ( !<sys-apps/openrc-0.13 )"
-
-S=${WORKDIR}/${MY_P}
+# TODO: Could make pkgconfig conditional on selinux? bug #782829
+RDEPEND="
+ !static? (
+ virtual/libc
+ virtual/libcrypt:=
+ selinux? ( sys-libs/libselinux )
+ )
+ pam? ( sys-libs/pam )
+"
+DEPEND="${RDEPEND}
+ static? (
+ virtual/libcrypt[static-libs]
+ selinux? ( sys-libs/libselinux[static-libs(+)] )
+ )
+ sys-kernel/linux-headers"
+BDEPEND="virtual/pkgconfig"
+
+DISABLE_AUTOFORMATTING=yes
+DOC_CONTENTS='
+If you want a smaller executable, add `-Oz` to your busybox `CFLAGS`.'
busybox_config_option() {
local flag=$1 ; shift
@@ -66,6 +78,11 @@ busybox_config_enabled() {
# patches go here!
PATCHES=(
"${FILESDIR}"/${PN}-1.26.2-bb.patch
+ "${FILESDIR}"/${PN}-1.34.1-skip-selinux-search.patch
+
+ "${FILESDIR}"/${PN}-1.36.0-fortify-source-3-fixdep.patch
+ "${FILESDIR}"/${PN}-1.36.1-kernel-6.8.patch
+
# "${FILESDIR}"/${P}-*.patch
)
@@ -79,11 +96,8 @@ src_prepare() {
# flag cleanup
sed -i -r \
- -e 's:[[:space:]]?-(Werror|Os|falign-(functions|jumps|loops|labels)=1|fomit-frame-pointer)\>::g' \
+ -e 's:[[:space:]]?-(Werror|Os|Oz|falign-(functions|jumps|loops|labels)=1|fomit-frame-pointer)\>::g' \
Makefile.flags || die
- #sed -i '/bbsh/s:^//::' include/applets.h
- sed -i '/^#error Aborting compilation./d' applets/applets.c || die
- use elibc_glibc && sed -i 's:-Wl,--gc-sections::' Makefile
sed -i \
-e "/^CROSS_COMPILE/s:=.*:= ${CHOST}-:" \
-e "/^AR\>/s:=.*:= $(tc-getAR):" \
@@ -94,6 +108,9 @@ src_prepare() {
sed -i \
-e 's:-static-libgcc::' \
Makefile.flags || die
+
+ # Print all link lines too
+ sed -i -e 's:debug=false:debug=true:' scripts/trylink || die
}
src_configure() {
@@ -108,12 +125,14 @@ src_configure() {
ewarn "Could not locate user configfile, so we will save a default one"
fi
+ # setting SKIP_SELINUX skips searching for selinux at this stage. We don't
+ # need to search now in case we end up not needing it after all.
# setup the config file
- emake -j1 -s allyesconfig >/dev/null
+ emake -j1 -s allyesconfig SKIP_SELINUX=$(usex selinux n y) >/dev/null #620918
# nommu forces a bunch of things off which we want on #387555
busybox_config_option n NOMMU
sed -i '/^#/d' .config
- yes "" | emake -j1 -s oldconfig >/dev/null
+ yes "" | emake -j1 -s oldconfig SKIP_SELINUX=$(usex selinux n y) >/dev/null #620918
# now turn off stuff we really don't want
busybox_config_option n DMALLOC
@@ -125,6 +144,10 @@ src_configure() {
busybox_config_option n MONOTONIC_SYSCALL
busybox_config_option n USE_PORTABLE_CODE
busybox_config_option n WERROR
+ # CONFIG_MODPROBE_SMALL=y disables depmod.c and uses a smaller one that
+ # does not support -b. Setting this to no creates slightly larger and
+ # slightly more useful modutils
+ busybox_config_option n MODPROBE_SMALL #472464
# triming the BSS size may be dangerous
busybox_config_option n FEATURE_USE_BSS_TAIL
@@ -135,7 +158,15 @@ src_configure() {
busybox_config_option n FEATURE_VI_REGEX_SEARCH
fi
- # If these are not set and we are using a uclibc/busybox setup
+ # Disable standalone shell mode when using make-symlinks, else Busybox calls its
+ # applets by default without looking up in PATH.
+ # This also enables users to disable a builtin by deleting the corresponding symlink.
+ if use make-symlinks; then
+ busybox_config_option n FEATURE_PREFER_APPLETS
+ busybox_config_option n FEATURE_SH_STANDALONE
+ fi
+
+ # If these are not set and we are using a busybox setup
# all calls to system() will fail.
busybox_config_option y ASH
busybox_config_option y SH_IS_ASH
@@ -145,26 +176,12 @@ src_configure() {
busybox_config_option '"/run"' PID_FILE_PATH
busybox_config_option '"/run/ifstate"' IFUPDOWN_IFSTATE_PATH
- # disable ipv6 applets
- if ! use ipv6; then
- busybox_config_option n FEATURE_IPV6
- busybox_config_option n TRACEROUTE6
- busybox_config_option n PING6
- busybox_config_option n UDHCPC6
- fi
-
busybox_config_option pam PAM
busybox_config_option static STATIC
busybox_config_option syslog {K,SYS}LOGD LOGGER
busybox_config_option systemd FEATURE_SYSTEMD
busybox_config_option math FEATURE_AWK_LIBM
- # disable features that uClibc doesn't (yet?) provide.
- if use elibc_uclibc; then
- busybox_config_option n FEATURE_SYNC_FANCY #567598
- busybox_config_option n NSENTER
- fi
-
# all the debug options are compiler related, so punt them
busybox_config_option n DEBUG_SANITIZE
busybox_config_option n DEBUG
@@ -213,6 +230,9 @@ src_compile() {
export SKIP_STRIP=y
emake V=1 busybox
+
+ # bug #701512
+ emake V=1 doc
}
src_install() {
@@ -234,7 +254,11 @@ src_install() {
if use mdev ; then
dodir /$(get_libdir)/mdev/
use make-symlinks || dosym /bin/bb /sbin/mdev
- cp "${S}"/examples/mdev_fat.conf "${ED}"/etc/mdev.conf
+ cp "${S}"/examples/mdev_fat.conf "${ED}"/etc/mdev.conf || die
+ if [[ ! "$(get_libdir)" == "lib" ]]; then
+ #831251 - replace lib with lib64 where appropriate
+ sed -i -e "s:/lib/:/$(get_libdir)/:g" "${ED}"/etc/mdev.conf || die
+ fi
exeinto /$(get_libdir)/mdev/
doexe "${FILESDIR}"/mdev/*
@@ -247,22 +271,23 @@ src_install() {
# add busybox daemon's, bug #444718
if busybox_config_enabled FEATURE_NTPD_SERVER; then
- newconfd "${FILESDIR}/ntpd.confd" "busybox-ntpd"
- newinitd "${FILESDIR}/ntpd.initd" "busybox-ntpd"
+ newconfd "${FILESDIR}"/ntpd.confd busybox-ntpd
+ newinitd "${FILESDIR}"/ntpd.initd busybox-ntpd
fi
if busybox_config_enabled SYSLOGD; then
- newconfd "${FILESDIR}/syslogd.confd" "busybox-syslogd"
- newinitd "${FILESDIR}/syslogd.initd" "busybox-syslogd"
+ newconfd "${FILESDIR}"/syslogd.confd busybox-syslogd
+ newinitd "${FILESDIR}"/syslogd.initd busybox-syslogd
fi
if busybox_config_enabled KLOGD; then
- newconfd "${FILESDIR}/klogd.confd" "busybox-klogd"
- newinitd "${FILESDIR}/klogd.initd" "busybox-klogd"
+ newconfd "${FILESDIR}"/klogd.confd busybox-klogd
+ newinitd "${FILESDIR}"/klogd.initd busybox-klogd
fi
if busybox_config_enabled WATCHDOG; then
- newconfd "${FILESDIR}/watchdog.confd" "busybox-watchdog"
- newinitd "${FILESDIR}/watchdog.initd" "busybox-watchdog"
+ newconfd "${FILESDIR}"/watchdog.confd busybox-watchdog
+ newinitd "${FILESDIR}"/watchdog.initd busybox-watchdog
fi
if busybox_config_enabled UDHCPC; then
+ sed -i 's:$((metric++)):$metric; metric=$((metric + 1)):' examples/udhcp/simple.script || die #801535
local path=$(busybox_config_enabled UDHCPC_DEFAULT_SCRIPT)
exeinto "${path%/*}"
newexe examples/udhcp/simple.script "${path##*/}"
@@ -271,20 +296,30 @@ src_install() {
insinto /etc
doins examples/udhcp/udhcpd.conf
fi
+ if busybox_config_enabled ASH && ! use make-symlinks; then
+ dosym -r /bin/busybox /bin/ash
+ fi
+ if busybox_config_enabled CROND; then
+ newconfd "${FILESDIR}"/crond.confd busybox-crond
+ newinitd "${FILESDIR}"/crond.initd busybox-crond
+ fi
# bundle up the symlink files for use later
emake DESTDIR="${ED}" install
- rm _install/bin/busybox
# for compatibility, provide /usr/bin/env
- mkdir -p _install/usr/bin
- ln -s /bin/env _install/usr/bin/env
+ mkdir -p _install/usr/bin || die
+ if [[ ! -e _install/usr/bin/env ]]; then
+ ln -s /bin/env _install/usr/bin/env || die
+ fi
+ rm _install/bin/busybox || die
tar cf busybox-links.tar -C _install . || : #;die
insinto /usr/share/${PN}
use make-symlinks && doins busybox-links.tar
dodoc AUTHORS README TODO
- cd docs
+ cd docs || die
+ doman busybox.1
docinto txt
dodoc *.txt
docinto pod
@@ -292,20 +327,17 @@ src_install() {
docinto html
dodoc *.html
- cd ../examples
+ cd ../examples || die
docinto examples
dodoc inittab depmod.pl *.conf *.script undeb unrpm
+
+ cd ../networking || die
+ dodoc httpd_indexcgi.c httpd_post_upload.cgi
+
+ readme.gentoo_create_doc
}
pkg_preinst() {
- if use make-symlinks && [[ ! ${VERY_BRAVE_OR_VERY_DUMB} == "yes" ]] && [[ ${ROOT} == "/" ]] ; then
- ewarn "setting USE=make-symlinks and emerging to / is very dangerous."
- ewarn "it WILL overwrite lots of system programs like: ls bash awk grep (bug 60805 for full list)."
- ewarn "If you are creating a binary only and not merging this is probably ok."
- ewarn "set env VERY_BRAVE_OR_VERY_DUMB=yes if this is really what you want."
- die "silly options will destroy your system"
- fi
-
if use make-symlinks ; then
mv "${ED}"/usr/share/${PN}/busybox-links.tar "${T}"/ || die
fi
@@ -318,7 +350,9 @@ pkg_postinst() {
cd "${T}" || die
mkdir _install
tar xf busybox-links.tar -C _install || die
- cp -vpPR _install/* "${ROOT}"/ || die "copying links for ${x} failed"
+ # 907432: cp -n returns error if it skips any file, but that is expected here
+ # TODO: check if a new coreutils release has a replacement option
+ cp -nvpPR _install/* "${ROOT}"/
fi
if use sep-usr ; then
@@ -330,4 +364,14 @@ pkg_postinst() {
elog "To get a rescue shell, you may boot with:"
elog " init=/ginit bb"
fi
+
+ if [[ ${MERGE_TYPE} != binary ]] && ! is-flagq -Oz; then
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test ${v} -le 1.36.1; then
+ FORCE_PRINT_ELOG=yes
+ fi
+ done
+
+ readme.gentoo_print_elog
+ fi
}