summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/clrngd/clrngd-1.0.3.ebuild')
-rw-r--r--sys-apps/clrngd/clrngd-1.0.3.ebuild21
1 files changed, 9 insertions, 12 deletions
diff --git a/sys-apps/clrngd/clrngd-1.0.3.ebuild b/sys-apps/clrngd/clrngd-1.0.3.ebuild
index eac515a1ff3c..6cc2a27825b2 100644
--- a/sys-apps/clrngd/clrngd-1.0.3.ebuild
+++ b/sys-apps/clrngd/clrngd-1.0.3.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+EAPI=6
+
DESCRIPTION="Clock randomness gathering daemon"
HOMEPAGE="http://echelon.pl/pubs/"
SRC_URI="http://echelon.pl/pubs/${P}.tar.gz"
@@ -8,19 +10,14 @@ SRC_URI="http://echelon.pl/pubs/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-
-DEPEND="sys-devel/gcc"
-RDEPEND=""
-src_compile() {
- econf --bindir=/usr/sbin || die
- emake || die
+src_configure() {
+ econf --bindir="${EPREFIX}"/usr/sbin
}
src_install() {
- make DESTDIR=${D} install || die "make install failed"
- dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
- newinitd ${FILESDIR}/clrngd-init.d clrngd
- newconfd ${FILESDIR}/clrngd-conf.d clrngd
+ default
+
+ newinitd "${FILESDIR}"/${PN}-init.d ${PN}
+ newconfd "${FILESDIR}"/${PN}-conf.d ${PN}
}