summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/dtc/dtc-1.6.0.ebuild')
-rw-r--r--sys-apps/dtc/dtc-1.6.0.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/sys-apps/dtc/dtc-1.6.0.ebuild b/sys-apps/dtc/dtc-1.6.0.ebuild
index 41acb4a8a9bc..6e285f4459f5 100644
--- a/sys-apps/dtc/dtc-1.6.0.ebuild
+++ b/sys-apps/dtc/dtc-1.6.0.ebuild
@@ -1,15 +1,16 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit multilib toolchain-funcs
+
+inherit toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/dtc/dtc.git"
inherit git-r3
else
SRC_URI="https://www.kernel.org/pub/software/utils/${PN}/${P}.tar.xz"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 ~sparc x86"
+ KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 ~sparc x86"
fi
DESCRIPTION="Open Firmware device tree compiler"
@@ -20,8 +21,8 @@ SLOT="0"
IUSE="static-libs yaml"
BDEPEND="
- sys-devel/bison
- sys-devel/flex
+ app-alternatives/yacc
+ app-alternatives/lex
virtual/pkgconfig
"
RDEPEND="yaml? ( dev-libs/libyaml )"