summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/elfix')
-rw-r--r--sys-apps/elfix/elfix-0.9.5.ebuild17
-rw-r--r--sys-apps/elfix/elfix-9999.ebuild17
-rw-r--r--sys-apps/elfix/metadata.xml4
3 files changed, 20 insertions, 18 deletions
diff --git a/sys-apps/elfix/elfix-0.9.5.ebuild b/sys-apps/elfix/elfix-0.9.5.ebuild
index 5113f837ed5e..0f1ed96f6f05 100644
--- a/sys-apps/elfix/elfix-0.9.5.ebuild
+++ b/sys-apps/elfix/elfix-0.9.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -8,7 +8,7 @@ if [[ ${PV} == *9999* ]] ; then
inherit autotools git-r3
else
SRC_URI="https://dev.gentoo.org/~blueness/elfix/${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86"
+ KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv sparc x86"
fi
DESCRIPTION="A suite of tools to work with ELF objects on Hardened Gentoo"
@@ -17,14 +17,12 @@ HOMEPAGE="https://www.gentoo.org/proj/en/hardened/pax-quickstart.xml
LICENSE="GPL-3"
SLOT="0"
-IUSE="+ptpax +xtpax"
-
-DOCS=( AUTHORS ChangeLog INSTALL README THANKS TODO )
-
+IUSE="+ptpax test +xtpax"
REQUIRED_USE="|| ( ptpax xtpax )"
-
# These only work with a properly configured PaX kernel
-RESTRICT="test"
+RESTRICT="!test? ( test ) test"
+
+DOCS=( AUTHORS ChangeLog INSTALL README THANKS TODO )
DEPEND="~dev-python/pypax-${PV}[ptpax=,xtpax=]
ptpax? ( dev-libs/elfutils )
@@ -42,7 +40,8 @@ src_prepare() {
src_configure() {
rm -f "${S}/scripts/setup.py"
- econf --disable-tests \
+ econf \
+ $(use_enable test tests) \
$(use_enable ptpax) \
$(use_enable xtpax)
}
diff --git a/sys-apps/elfix/elfix-9999.ebuild b/sys-apps/elfix/elfix-9999.ebuild
index a7a57400096c..05b415e1f5d3 100644
--- a/sys-apps/elfix/elfix-9999.ebuild
+++ b/sys-apps/elfix/elfix-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -8,7 +8,7 @@ if [[ ${PV} == *9999* ]] ; then
inherit autotools git-r3
else
SRC_URI="https://dev.gentoo.org/~blueness/elfix/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
DESCRIPTION="A suite of tools to work with ELF objects on Hardened Gentoo"
@@ -17,14 +17,12 @@ HOMEPAGE="https://www.gentoo.org/proj/en/hardened/pax-quickstart.xml
LICENSE="GPL-3"
SLOT="0"
-IUSE="+ptpax +xtpax"
-
-DOCS=( AUTHORS ChangeLog INSTALL README THANKS TODO )
-
+IUSE="+ptpax test +xtpax"
REQUIRED_USE="|| ( ptpax xtpax )"
-
# These only work with a properly configured PaX kernel
-RESTRICT="test"
+RESTRICT="!test? ( test ) test"
+
+DOCS=( AUTHORS ChangeLog INSTALL README THANKS TODO )
DEPEND="~dev-python/pypax-${PV}[ptpax=,xtpax=]
ptpax? ( dev-libs/elfutils )
@@ -42,7 +40,8 @@ src_prepare() {
src_configure() {
rm -f "${S}/scripts/setup.py"
- econf --disable-tests \
+ econf \
+ $(use_enable test tests) \
$(use_enable ptpax) \
$(use_enable xtpax)
}
diff --git a/sys-apps/elfix/metadata.xml b/sys-apps/elfix/metadata.xml
index 059e15008dea..ce910eb81c8a 100644
--- a/sys-apps/elfix/metadata.xml
+++ b/sys-apps/elfix/metadata.xml
@@ -13,4 +13,8 @@
<flag name="xtpax">Enable XATTR_PAX_FLAGS support.</flag>
<flag name="ptpax">Enable PT_PAX_FLAGS support.</flag>
</use>
+ <upstream>
+ <remote-id type="gentoo">proj/elfix</remote-id>
+ <remote-id type="github">gentoo/elfix</remote-id>
+ </upstream>
</pkgmetadata>