summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/elfix')
-rw-r--r--sys-apps/elfix/Manifest2
-rw-r--r--sys-apps/elfix/elfix-0.8.4.ebuild38
-rw-r--r--sys-apps/elfix/elfix-0.9.0-r1.ebuild45
-rw-r--r--sys-apps/elfix/files/elfix-0.9.0-backport-fix-paxmark_sh.patch57
-rw-r--r--sys-apps/elfix/files/elfix-0.9.0-backport-fix-revdep-pax.patch25
-rw-r--r--sys-apps/elfix/metadata.xml13
6 files changed, 180 insertions, 0 deletions
diff --git a/sys-apps/elfix/Manifest b/sys-apps/elfix/Manifest
new file mode 100644
index 000000000000..71ba474647dc
--- /dev/null
+++ b/sys-apps/elfix/Manifest
@@ -0,0 +1,2 @@
+DIST elfix-0.8.4.tar.gz 374742 SHA256 374be66da3dddef485bbb5e95bfcab6fd0c2db478255bddd10079730ada5260b SHA512 10aacc3fff33c934e2d4487d174a2b0cec10ffb7a35fc72b160c786f82f0355f3a2dea716bc7fb929d2919cc32a26844f37f9d73064b755098bdaa72e8075bda WHIRLPOOL b04e099f188c0b76d8c07abd76559c1313854aa83a03ad69afb72674d93cde6ce538ae10d0fea3be5495937e72a4b98fdd36efbb2e3aa8ff23c1d9f7f943c1ae
+DIST elfix-0.9.0.tar.gz 372014 SHA256 8b547d987edb2f7dc23ddf30f959d7d051a9ed49810f983b8fe6c489fe731cf0 SHA512 fd9bab90d745f77429c902acd2a14f615132731b3c38929dce764f1e5f7ee8f6478a6fef7ce0cb38e7ebd9181ba57965ff0c97da5e01d0fbf2cfb940ed691ebf WHIRLPOOL c09fa2193b990a506cae17f370ec10fa6302e17d2a165e42eceb88644f8a92e297c839ad788204e213d8205695b65557a7dcef5f6417177c434c8d0a34bd5eb7
diff --git a/sys-apps/elfix/elfix-0.8.4.ebuild b/sys-apps/elfix/elfix-0.8.4.ebuild
new file mode 100644
index 000000000000..15bc8083ce0d
--- /dev/null
+++ b/sys-apps/elfix/elfix-0.8.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="A suite of tools to work with ELF objects on Hardened Gentoo"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/pax-quickstart.xml
+ http://dev.gentoo.org/~blueness/elfix/"
+SRC_URI="http://dev.gentoo.org/~blueness/elfix/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86"
+IUSE="+ptpax +xtpax"
+
+REQUIRED_USE="|| ( ptpax xtpax )"
+
+# These only work with a properly configured PaX kernel
+RESTRICT="test"
+
+DEPEND="~dev-python/pypax-${PV}[ptpax=,xtpax=]
+ ptpax? ( dev-libs/elfutils )
+ xtpax? ( sys-apps/attr )"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ rm -f "${S}/scripts/setup.py"
+ econf --disable-tests \
+ $(use_enable ptpax) \
+ $(use_enable xtpax)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog INSTALL README THANKS TODO
+}
diff --git a/sys-apps/elfix/elfix-0.9.0-r1.ebuild b/sys-apps/elfix/elfix-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..38150a85e180
--- /dev/null
+++ b/sys-apps/elfix/elfix-0.9.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="A suite of tools to work with ELF objects on Hardened Gentoo"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/pax-quickstart.xml
+ http://dev.gentoo.org/~blueness/elfix/"
+SRC_URI="http://dev.gentoo.org/~blueness/elfix/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86"
+IUSE="+ptpax +xtpax"
+
+REQUIRED_USE="|| ( ptpax xtpax )"
+
+# These only work with a properly configured PaX kernel
+RESTRICT="test"
+
+DEPEND="~dev-python/pypax-${PV}[ptpax=,xtpax=]
+ ptpax? ( dev-libs/elfutils )
+ xtpax? ( sys-apps/attr )"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-backport-fix-paxmark_sh.patch
+ epatch "${FILESDIR}"/${P}-backport-fix-revdep-pax.patch
+}
+
+src_configure() {
+ rm -f "${S}/scripts/setup.py"
+ econf --disable-tests \
+ $(use_enable ptpax) \
+ $(use_enable xtpax)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog INSTALL README THANKS TODO
+}
diff --git a/sys-apps/elfix/files/elfix-0.9.0-backport-fix-paxmark_sh.patch b/sys-apps/elfix/files/elfix-0.9.0-backport-fix-paxmark_sh.patch
new file mode 100644
index 000000000000..86be00ee46c2
--- /dev/null
+++ b/sys-apps/elfix/files/elfix-0.9.0-backport-fix-paxmark_sh.patch
@@ -0,0 +1,57 @@
+From 84ca11706f804d6c808d932700a90cc8eaab2f15 Mon Sep 17 00:00:00 2001
+From: "Anthony G. Basile" <blueness@gentoo.org>
+Date: Sun, 21 Dec 2014 10:37:00 -0500
+Subject: [PATCH 1/2] scripts/paxmark.sh: source make.conf and properly set
+ PAX_MARKINGS
+
+---
+ ChangeLog | 6 ++++++
+ scripts/paxmark.sh | 6 +++---
+ 2 files changed, 9 insertions(+), 3 deletions(-)
+
+diff --git a/ChangeLog b/ChangeLog
+index f64e57a..d9993b1 100644
+--- a/ChangeLog
++++ b/ChangeLog
+@@ -1,3 +1,9 @@
++2014-12-22
++
++ * scripts/paxmark.sh: remove erroneous elog functions
++ * scripts/paxmark.sh: source /etc/portage/make.conf for PAX_MARKINGS
++ and correct logic to default to PT only if no PAX_MARKINGS are set.
++ Reported by Karl-Johan Karlsson <creideiki+gentoo-hardened@ferretporn.se>
+
+ 2014-10-03
+
+diff --git a/scripts/paxmark.sh b/scripts/paxmark.sh
+index 9ec077a..408e6aa 100755
+--- a/scripts/paxmark.sh
++++ b/scripts/paxmark.sh
+@@ -53,7 +53,6 @@ paxmarksh() {
+ scanelf -Xxz ${flags} "$f" >/dev/null 2>&1
+ #We failed to set PT_PAX flags
+ elif [[ ${PAX_MARKINGS} != "none" ]]; then
+- elog "Failed to set PT_PAX markings -${flags} ${f}."
+ ret=1
+ fi
+ done
+@@ -79,7 +78,6 @@ paxmarksh() {
+
+ #We failed to set XATTR_PAX flags
+ if [[ ${PAX_MARKINGS} != "none" ]]; then
+- elog "Failed to set XATTR_PAX markings -${flags} ${f}."
+ ret=1
+ fi
+ done
+@@ -88,5 +86,7 @@ paxmarksh() {
+ return ${ret}
+ }
+
+-PAX_MARKINGS=${PAX_MARKINGS:="PT XT"}
++MAKE_CONF="/etc/portage/make.conf"
++[[ -e $MAKE_CONF ]] && source $MAKE_CONF
++PAX_MARKINGS=${PAX_MARKINGS:="PT"}
+ paxmarksh "$@"
+--
+2.0.5
+
diff --git a/sys-apps/elfix/files/elfix-0.9.0-backport-fix-revdep-pax.patch b/sys-apps/elfix/files/elfix-0.9.0-backport-fix-revdep-pax.patch
new file mode 100644
index 000000000000..e92769eece76
--- /dev/null
+++ b/sys-apps/elfix/files/elfix-0.9.0-backport-fix-revdep-pax.patch
@@ -0,0 +1,25 @@
+From 581b53b3c1ca3166dc394d1f4b08260bd088c346 Mon Sep 17 00:00:00 2001
+From: "Anthony G. Basile" <blueness@gentoo.org>
+Date: Mon, 22 Dec 2014 12:30:12 -0500
+Subject: [PATCH 2/2] scripts/revdep-pax: change .get_maps() to .get_graph()
+
+---
+ scripts/revdep-pax | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/scripts/revdep-pax b/scripts/revdep-pax
+index a718fd6..7c1cf85 100755
+--- a/scripts/revdep-pax
++++ b/scripts/revdep-pax
+@@ -465,7 +465,7 @@ def run_soname(name, verbose, use_soname, mark, allyes, executable_only):
+ shell_path = os.getenv('PATH').split(':')
+
+ (object_linkings, object_reverse_linkings,
+- library2soname, soname2library) = LinkGraph().get_maps()
++ library2soname, soname2library) = LinkGraph().get_graph()
+
+ if use_soname:
+ soname = name
+--
+2.0.5
+
diff --git a/sys-apps/elfix/metadata.xml b/sys-apps/elfix/metadata.xml
new file mode 100644
index 000000000000..870245044b50
--- /dev/null
+++ b/sys-apps/elfix/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>hardened</herd>
+ <maintainer>
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <use>
+ <flag name='xtpax'>Enable XATTR_PAX_FLAGS support.</flag>
+ <flag name='ptpax'>Enable PT_PAX_FLAGS support.</flag>
+ </use>
+</pkgmetadata>