summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/ethtool/ethtool-5.16.ebuild')
-rw-r--r--sys-apps/ethtool/ethtool-5.16.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/sys-apps/ethtool/ethtool-5.16.ebuild b/sys-apps/ethtool/ethtool-5.16.ebuild
new file mode 100644
index 000000000000..ac936a3334cd
--- /dev/null
+++ b/sys-apps/ethtool/ethtool-5.16.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Utility for examining and tuning ethernet-based network interfaces"
+HOMEPAGE="https://www.kernel.org/pub/software/network/ethtool/"
+SRC_URI="https://www.kernel.org/pub/software/network/ethtool/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+netlink"
+
+BDEPEND="app-arch/xz-utils"
+RDEPEND="netlink? ( net-libs/libmnl )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf $(use_enable netlink)
+}