summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/fbset/fbset-2.1.ebuild')
-rw-r--r--sys-apps/fbset/fbset-2.1.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/sys-apps/fbset/fbset-2.1.ebuild b/sys-apps/fbset/fbset-2.1.ebuild
index cd50cd3945d2..1c334fdbfb9f 100644
--- a/sys-apps/fbset/fbset-2.1.ebuild
+++ b/sys-apps/fbset/fbset-2.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+EAPI=6
+
inherit toolchain-funcs flag-o-matic eutils
DESCRIPTION="A utility to set the framebuffer videomode"
@@ -16,10 +18,10 @@ DEPEND="sys-devel/bison
sys-devel/flex"
RDEPEND=""
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}/${P}-build.patch"
+ epatch "${FILESDIR}/${P}-add-linux-types-h.patch"
+ default
}
src_compile() {