summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/fbset')
-rw-r--r--sys-apps/fbset/fbset-2.1.ebuild10
-rw-r--r--sys-apps/fbset/files/fbset-2.1-add-linux-types-h.patch11
2 files changed, 17 insertions, 4 deletions
diff --git a/sys-apps/fbset/fbset-2.1.ebuild b/sys-apps/fbset/fbset-2.1.ebuild
index cd50cd3945d2..1c334fdbfb9f 100644
--- a/sys-apps/fbset/fbset-2.1.ebuild
+++ b/sys-apps/fbset/fbset-2.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+EAPI=6
+
inherit toolchain-funcs flag-o-matic eutils
DESCRIPTION="A utility to set the framebuffer videomode"
@@ -16,10 +18,10 @@ DEPEND="sys-devel/bison
sys-devel/flex"
RDEPEND=""
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}/${P}-build.patch"
+ epatch "${FILESDIR}/${P}-add-linux-types-h.patch"
+ default
}
src_compile() {
diff --git a/sys-apps/fbset/files/fbset-2.1-add-linux-types-h.patch b/sys-apps/fbset/files/fbset-2.1-add-linux-types-h.patch
new file mode 100644
index 000000000000..589d61b0ee8b
--- /dev/null
+++ b/sys-apps/fbset/files/fbset-2.1-add-linux-types-h.patch
@@ -0,0 +1,11 @@
+--- a/fbset.h 2018-04-05 18:17:18.292975594 +0000
++++ b/fbset.h 2018-04-05 18:22:20.448747231 +0000
+@@ -17,6 +17,8 @@
+
+ #ifdef __GLIBC__
+ #include <asm/types.h>
++#else
++#include <linux/types.h>
+ #endif
+
+ #define VERSION "Linux Frame Buffer Device Configuration " \