summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-2.ebuild')
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-2.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-2.ebuild
new file mode 100644
index 000000000000..4f63e11be5db
--- /dev/null
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils systemd
+
+DESCRIPTION="systemd integration files for Gentoo"
+HOMEPAGE="https://bitbucket.org/mgorny/gentoo-systemd-integration"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND=">=sys-apps/systemd-207"
+
+src_configure() {
+ local myeconfargs=(
+ "$(systemd_with_unitdir)"
+ # TODO: solve it better in the eclass
+ --with-systemdsystemgeneratordir="$(systemd_get_utildir)"/system-generators
+ )
+
+ autotools-utils_src_configure
+}