summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/groff')
-rw-r--r--sys-apps/groff/groff-1.22.4.ebuild25
1 files changed, 12 insertions, 13 deletions
diff --git a/sys-apps/groff/groff-1.22.4.ebuild b/sys-apps/groff/groff-1.22.4.ebuild
index 8ec07c8c1ad7..3fa2e5096624 100644
--- a/sys-apps/groff/groff-1.22.4.ebuild
+++ b/sys-apps/groff/groff-1.22.4.ebuild
@@ -47,18 +47,6 @@ src_prepare() {
Makefile.in \
|| die "failed to modify Makefile.in"
- # Make sure we can cross-compile this puppy
- if tc-is-cross-compiler ; then
- sed -i \
- -e '/^GROFFBIN=/s:=.*:=${EPREFIX}/usr/bin/groff:' \
- -e '/^TROFFBIN=/s:=.*:=${EPREFIX}/usr/bin/troff:' \
- -e '/^GROFF_BIN_PATH=/s:=.*:=:' \
- -e '/^GROFF_BIN_DIR=/s:=.*:=:' \
- contrib/*/Makefile.sub \
- doc/Makefile.in \
- doc/Makefile.sub || die "cross-compile sed failed"
- fi
-
local pfx=$(usex prefix ' Prefix' '')
cat <<-EOF >> tmac/mdoc.local
.ds volume-operating-system Gentoo${pfx}
@@ -80,7 +68,18 @@ src_configure() {
}
src_compile() {
- emake AR="$(tc-getAR)"
+ if tc-is-cross-compiler ; then
+ local CROSS_ARGS=(
+ GROFFBIN="$(type -P groff)"
+ TROFFBIN="$(type -P troff)"
+ GROFF_BIN_DIR=
+ GROFF_BIN_PATH=
+ )
+ else
+ unset CROSS_ARGS
+ fi
+
+ emake AR="$(tc-getAR)" "${CROSS_ARGS[@]}"
}
src_install() {