summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/hdparm/files')
-rw-r--r--sys-apps/hdparm/files/hdparm-9.60-build.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-apps/hdparm/files/hdparm-9.60-build.patch b/sys-apps/hdparm/files/hdparm-9.60-build.patch
new file mode 100644
index 000000000000..7decf805c53a
--- /dev/null
+++ b/sys-apps/hdparm/files/hdparm-9.60-build.patch
@@ -0,0 +1,28 @@
+--- hdparm-9.60/Makefile
++++ hdparm-9.60/Makefile
+@@ -13,7 +13,7 @@
+ CC ?= gcc
+ STRIP ?= strip
+
+-CFLAGS := -O2 -W -Wall -Wbad-function-cast -Wcast-align -Wpointer-arith -Wcast-qual -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -fkeep-inline-functions -Wwrite-strings -Waggregate-return -Wnested-externs -Wtrigraphs $(CFLAGS)
++CFLAGS += -W -Wall -Wbad-function-cast -Wcast-align -Wpointer-arith -Wcast-qual -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -fkeep-inline-functions -Wwrite-strings -Waggregate-return -Wnested-externs -Wtrigraphs
+
+ INSTALL = install
+ INSTALL_DATA = $(INSTALL) -m 644
+@@ -22,14 +22,13 @@
+
+ OBJS = hdparm.o identify.o sgio.o sysfs.o geom.o fallocate.o fibmap.o fwdownload.o dvdspeed.o wdidle3.o apt.o
+
+-all:
+- $(MAKE) -j4 hdparm
++all: hdparm
+
+ static:
+ LDFLAGS=-static $(MAKE)
+
+ hdparm: Makefile hdparm.h sgio.h $(OBJS)
+- $(CC) $(LDFLAGS) -o hdparm $(OBJS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o hdparm $(OBJS)
+ $(STRIP) hdparm
+
+ hdparm.o: hdparm.h sgio.h