summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/hponcfg/hponcfg-5.2.0.0.ebuild')
-rw-r--r--sys-apps/hponcfg/hponcfg-5.2.0.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/hponcfg/hponcfg-5.2.0.0.ebuild b/sys-apps/hponcfg/hponcfg-5.2.0.0.ebuild
new file mode 100644
index 000000000000..d7eab2b4e3c2
--- /dev/null
+++ b/sys-apps/hponcfg/hponcfg-5.2.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit pax-utils rpm versionator
+
+MY_PV=$(replace_version_separator 3 '-')
+
+DESCRIPTION="HP Lights-Out Online Configuration Utility (HPONCFG)"
+HOMEPAGE="http://h20564.www2.hpe.com/hpsc/swd/public/detail?swItemId=MTX_5ab6295f49964f16a699064f29"
+SRC_URI="amd64? ( https://downloads.linux.hpe.com/SDR/repo/spp/RHEL/7/x86_64/current/${PN}-${MY_PV}.x86_64.rpm )"
+
+LICENSE="hpe"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="elibc_glibc? ( >sys-libs/glibc-2.14 )"
+
+S="${WORKDIR}"
+
+QA_PRESTRIPPED="/usr/sbin/hponcfg /usr/li.*/libcpqc.*"
+QA_PREBUILT="/usr/sbin/hponcfg"
+
+src_install() {
+ dosbin sbin/hponcfg
+
+ # When bumping, verify SONAME (scanelf -S libhponcfg64.so)!
+ newlib.so "${S}"/usr/lib64/libhponcfg64.so libcpqci64.so.3
+ dosym libcpqci64.so.3 /usr/$(get_libdir)/libhponcfg64.so
+
+ dodoc "${S}"/usr/share/doc/hponcfg/*
+
+ pax-mark m "${D}"usr/sbin/hponcfg
+}