summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/kbd/kbd-9999.ebuild')
-rw-r--r--sys-apps/kbd/kbd-9999.ebuild25
1 files changed, 4 insertions, 21 deletions
diff --git a/sys-apps/kbd/kbd-9999.ebuild b/sys-apps/kbd/kbd-9999.ebuild
index d0f3a2573fa7..a8607b2c1f1d 100644
--- a/sys-apps/kbd/kbd-9999.ebuild
+++ b/sys-apps/kbd/kbd-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
if [[ ${PV} == 9999 ]] ; then
inherit autotools git-r3
@@ -43,24 +43,17 @@ BDEPEND="
test? ( dev-libs/check )
"
-src_unpack() {
- if [[ ${PV} == 9999 ]] ; then
- git-r3_src_unpack
- else
- default
- fi
-}
-
src_prepare() {
default
# Rename conflicting keymaps to have unique names, bug #293228
# See also https://github.com/legionus/kbd/issues/76.
- cd "${S}"/data/keymaps/i386 || die
+ pushd "${S}"/data/keymaps/i386 &> /dev/null || die
mv fgGIod/trf.map fgGIod/trf-fgGIod.map || die
mv olpc/es.map olpc/es-olpc.map || die
mv olpc/pt.map olpc/pt-olpc.map || die
mv qwerty/cz.map qwerty/cz-qwerty.map || die
+ popd &> /dev/null || die
if [[ ${PV} == 9999 ]] || [[ $(ver_cut 3) -ge 90 ]] ; then
eautoreconf
@@ -69,9 +62,8 @@ src_prepare() {
src_configure() {
local myeconfargs=(
- # USE="test" installs .a files
- --disable-static
--disable-werror
+
$(use_enable nls)
$(use_enable pam vlock)
$(use_enable test tests)
@@ -80,15 +72,6 @@ src_configure() {
econf "${myeconfargs[@]}"
}
-src_test() {
- # Cheesy hack for now for https://github.com/legionus/kbd/issues/76
- mv "${S}"/data/keymaps/i386/qwerty/cz-qwerty.map "${S}"/data/keymaps/i386/qwerty/cz.map || die
-
- default
-
- mv "${S}"/data/keymaps/i386/qwerty/cz.map "${S}"/data/keymaps/i386/qwerty/cz-qwerty.map || die
-}
-
src_install() {
default