summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/pcsc-tools/pcsc-tools-1.4.23.ebuild')
-rw-r--r--sys-apps/pcsc-tools/pcsc-tools-1.4.23.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/sys-apps/pcsc-tools/pcsc-tools-1.4.23.ebuild b/sys-apps/pcsc-tools/pcsc-tools-1.4.23.ebuild
deleted file mode 100644
index f00141faee11..000000000000
--- a/sys-apps/pcsc-tools/pcsc-tools-1.4.23.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-inherit eutils fdo-mime multilib toolchain-funcs
-
-DESCRIPTION="PC/SC Architecture smartcard tools"
-HOMEPAGE="http://ludovic.rousseau.free.fr/softwares/pcsc-tools/"
-SRC_URI="http://ludovic.rousseau.free.fr/softwares/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
-IUSE="gtk network-cron"
-
-RDEPEND=">=sys-apps/pcsc-lite-1.4.14"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-RDEPEND="${RDEPEND}
- dev-perl/pcsc-perl
- gtk? ( dev-perl/gtk2-perl )"
-
-src_prepare() {
- sed -i -e 's:-Wall -O2:$(CFLAGS):g' Makefile
-}
-
-src_compile() {
- # explicitly only build the pcsc_scan application, or the man
- # pages will be gzipped first, and then unpacked.
- emake pcsc_scan CC=$(tc-getCC)
-}
-
-src_install() {
- # install manually, makes it much easier since the Makefile
- # requires fiddling with
- dobin ATR_analysis scriptor pcsc_scan
- doman pcsc_scan.1 scriptor.1p ATR_analysis.1p
-
- dodoc README Changelog
-
- if use gtk; then
- domenu gscriptor.desktop
- dobin gscriptor
- doman gscriptor.1p
- fi
-
- if use network-cron ; then
- exeinto /etc/cron.monthly
- newexe "${FILESDIR}"/smartcard.cron update-smartcard_list
- fi
-
- insinto /usr/share/pcsc
- doins smartcard_list.txt
-}
-
-pkg_postinst() {
- use gtk && fdo-mime_desktop_database_update
-}
-
-pkg_postrm() {
- fdo-mime_desktop_database_update
-}