summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/pcsc-tools/pcsc-tools-1.6.0.ebuild')
-rw-r--r--sys-apps/pcsc-tools/pcsc-tools-1.6.0.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/sys-apps/pcsc-tools/pcsc-tools-1.6.0.ebuild b/sys-apps/pcsc-tools/pcsc-tools-1.6.0.ebuild
new file mode 100644
index 000000000000..76cab41d9392
--- /dev/null
+++ b/sys-apps/pcsc-tools/pcsc-tools-1.6.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop toolchain-funcs xdg-utils
+
+DESCRIPTION="PC/SC Architecture smartcard tools"
+HOMEPAGE="http://ludovic.rousseau.free.fr/softwares/pcsc-tools/ https://github.com/LudovicRousseau/pcsc-tools"
+SRC_URI="http://ludovic.rousseau.free.fr/softwares/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="gui network-cron"
+
+DEPEND=">=sys-apps/pcsc-lite-1.4.14"
+RDEPEND="
+ ${DEPEND}
+ dev-perl/pcsc-perl
+ gui? ( dev-perl/Gtk3 )
+"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=(
+ README Changelog
+)
+
+src_compile() {
+ # explicitly only build the pcsc_scan application, or the man
+ # pages will be gzipped first, and then unpacked.
+ emake pcsc_scan CC="$(tc-getCC)"
+}
+
+src_install() {
+ einstalldocs
+
+ # install manually, makes it much easier since the Makefile
+ # requires fiddling with
+ dobin ATR_analysis scriptor pcsc_scan
+ doman pcsc_scan.1 scriptor.1p ATR_analysis.1p
+
+ if use gui; then
+ domenu gscriptor.desktop
+ dobin gscriptor
+ doman gscriptor.1p
+ fi
+
+ if use network-cron ; then
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/smartcard.cron update-smartcard_list
+ fi
+
+ insinto /usr/share/pcsc
+ doins smartcard_list.txt
+}
+
+pkg_postinst() {
+ use gui && xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}