summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/systemd/systemd-249.6.ebuild')
-rw-r--r--sys-apps/systemd/systemd-249.6.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-apps/systemd/systemd-249.6.ebuild b/sys-apps/systemd/systemd-249.6.ebuild
index 1370a0cb30e6..6671b0b73702 100644
--- a/sys-apps/systemd/systemd-249.6.ebuild
+++ b/sys-apps/systemd/systemd-249.6.ebuild
@@ -177,7 +177,7 @@ pkg_pretend() {
fi
local CONFIG_CHECK="~AUTOFS4_FS ~BLK_DEV_BSG ~CGROUPS
- ~KCMP ~DEVTMPFS ~EPOLL ~FANOTIFY ~FHANDLE
+ ~DEVTMPFS ~EPOLL ~FANOTIFY ~FHANDLE
~INOTIFY_USER ~IPV6 ~NET ~NET_NS ~PROC_FS ~SIGNALFD ~SYSFS
~TIMERFD ~TMPFS_XATTR ~UNIX ~USER_NS
~CRYPTO_HMAC ~CRYPTO_SHA256 ~CRYPTO_USER_API_HASH
@@ -190,6 +190,12 @@ pkg_pretend() {
kernel_is -lt 4 7 && CONFIG_CHECK+=" ~DEVPTS_MULTIPLE_INSTANCES"
kernel_is -ge 4 10 && CONFIG_CHECK+=" ~CGROUP_BPF"
+ if kernel_is -lt 5 10 20; then
+ CONFIG_CHECK+=" ~CHECKPOINT_RESTORE"
+ else
+ CONFIG_CHECK+=" ~KCMP"
+ fi
+
if linux_config_exists; then
local uevent_helper_path=$(linux_chkconfig_string UEVENT_HELPER_PATH)
if [[ -n ${uevent_helper_path} ]] && [[ ${uevent_helper_path} != '""' ]]; then