summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/util-linux/util-linux-9999.ebuild')
-rw-r--r--sys-apps/util-linux/util-linux-9999.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/sys-apps/util-linux/util-linux-9999.ebuild b/sys-apps/util-linux/util-linux-9999.ebuild
index cfaef7723246..f1759d4eb6c3 100644
--- a/sys-apps/util-linux/util-linux-9999.ebuild
+++ b/sys-apps/util-linux/util-linux-9999.ebuild
@@ -92,12 +92,6 @@ src_prepare() {
eautoreconf
fi
- # Undo bad ncurses handling by upstream. #601530
- sed -i -E \
- -e '/NCURSES_/s:(ncursesw?)[56]-config:$PKG_CONFIG \1:' \
- -e 's:(ncursesw?)[56]-config --version:$PKG_CONFIG --exists --print-errors \1:' \
- configure || die
-
elibtoolize
}
@@ -144,6 +138,10 @@ multilib_src_configure() {
export ac_cv_header_security_pam_misc_h=$(multilib_native_usex pam) #485486
export ac_cv_header_security_pam_appl_h=$(multilib_native_usex pam) #545042
+ # Undo bad ncurses handling by upstream. Fall back to pkg-config. #601530
+ export NCURSES6_CONFIG=false NCURSES5_CONFIG=false
+ export NCURSESW6_CONFIG=false NCURSESW5_CONFIG=false
+
# configure args shared by python and non-python builds
local commonargs=(
--enable-fs-paths-extra="${EPREFIX}/usr/sbin:${EPREFIX}/bin:${EPREFIX}/usr/bin"