summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/pambase/pambase-20190402.ebuild')
-rw-r--r--sys-auth/pambase/pambase-20190402.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sys-auth/pambase/pambase-20190402.ebuild b/sys-auth/pambase/pambase-20190402.ebuild
index 561f79c02e7a..6f2cd170ef2e 100644
--- a/sys-auth/pambase/pambase-20190402.ebuild
+++ b/sys-auth/pambase/pambase-20190402.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="PAM base configuration files"
HOMEPAGE="https://github.com/gentoo/pambase"
SRC_URI="https://github.com/gentoo/pambase/archive/${P}.tar.gz"
@@ -62,6 +64,7 @@ src_compile() {
emake \
GIT=true \
+ CPP="$(tc-getPROG CPP cpp)" \
$(use_var debug) \
$(use_var cracklib) \
$(use_var passwdqc) \
@@ -83,5 +86,5 @@ src_compile() {
src_test() { :; }
src_install() {
- emake GIT=true DESTDIR="${ED}" install
+ emake GIT=true CPP="$(tc-getPROG CPP cpp)" DESTDIR="${ED}" install
}