summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/realtime-base/realtime-base-0.1.ebuild')
-rw-r--r--sys-auth/realtime-base/realtime-base-0.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-auth/realtime-base/realtime-base-0.1.ebuild b/sys-auth/realtime-base/realtime-base-0.1.ebuild
new file mode 100644
index 000000000000..bf2defe7147e
--- /dev/null
+++ b/sys-auth/realtime-base/realtime-base-0.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit user
+
+DESCRIPTION="Sets up realtime scheduling"
+HOMEPAGE="http://www.jackaudio.org/linux_rt_config"
+SRC_URI=""
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~amd64-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND="virtual/pam"
+
+limitsdfile=40-${PN}.conf
+rtgroup=realtime
+
+S=${WORKDIR}
+
+pkg_setup() {
+ enewgroup ${rtgroup}
+}
+
+print_limitsdfile() {
+ printf "# Start of ${limitsdfile} from ${P}\n\n"
+ printf "@${rtgroup}\t-\trtprio\t99\n"
+ printf "@${rtgroup}\t-\tmemlock\tunlimited\n"
+ printf "\n# End of ${limitsdfile} from ${P}\n"
+}
+
+src_compile() {
+ einfo "Generating ${limitsdfile}"
+ print_limitsdfile > "${S}/${limitsdfile}"
+}
+
+src_install() {
+ insinto /etc/security/limits.d/
+ doins "${S}/${limitsdfile}" || die
+}
+
+pkg_postinst() {
+ elog "We have added realtime scheduling privileges for users in the ${rtgroup} group."
+ elog "Please make sure users needing such privileges are in that group."
+}