summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/rtkit/rtkit-0.11-r2.ebuild')
-rw-r--r--sys-auth/rtkit/rtkit-0.11-r2.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/sys-auth/rtkit/rtkit-0.11-r2.ebuild b/sys-auth/rtkit/rtkit-0.11-r2.ebuild
deleted file mode 100644
index f39c932527cb..000000000000
--- a/sys-auth/rtkit/rtkit-0.11-r2.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils systemd user autotools linux-info
-
-DESCRIPTION="Realtime Policy and Watchdog Daemon"
-HOMEPAGE="https://0pointer.de/blog/projects/rtkit"
-SRC_URI="https://0pointer.de/public/${P}.tar.xz"
-
-LICENSE="GPL-3 BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 sparc x86"
-IUSE=""
-
-RDEPEND="
- sys-apps/dbus
- sys-auth/polkit
- sys-libs/libcap
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- # Fedora patches
- "${FILESDIR}/${P}-polkit.patch"
- "${FILESDIR}/${P}-gettime.patch"
- "${FILESDIR}/${P}-controlgroup.patch"
-)
-
-pkg_pretend() {
- if use kernel_linux; then
- CONFIG_CHECK="~!RT_GROUP_SCHED"
- ERROR_RT_GROUP_SCHED="CONFIG_RT_GROUP_SCHED is enabled. rtkit-daemon (or any other "
- ERROR_RT_GROUP_SCHED+="real-time task) will not work unless run as root. Please consider "
- ERROR_RT_GROUP_SCHED+="unsetting this option."
- check_extra_config
- fi
-}
-
-pkg_setup() {
- enewgroup rtkit
- enewuser rtkit -1 -1 -1 "rtkit"
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
-}
-
-src_install() {
- default
-
- ./rtkit-daemon --introspect > org.freedesktop.RealtimeKit1.xml
- insinto /usr/share/dbus-1/interfaces
- doins org.freedesktop.RealtimeKit1.xml
-}