summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/disktype')
-rw-r--r--sys-block/disktype/disktype-9-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-block/disktype/disktype-9-r1.ebuild b/sys-block/disktype/disktype-9-r1.ebuild
new file mode 100644
index 000000000000..ebfafa2cc36f
--- /dev/null
+++ b/sys-block/disktype/disktype-9-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Detect the content format of a disk or disk image"
+HOMEPAGE="http://disktype.sourceforge.net/"
+SRC_URI="mirror://sourceforge/disktype/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin disktype
+ dodoc README HISTORY TODO
+ doman disktype.1
+}