summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/fwdl/fwdl-1.2.3.ebuild')
-rw-r--r--sys-block/fwdl/fwdl-1.2.3.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/sys-block/fwdl/fwdl-1.2.3.ebuild b/sys-block/fwdl/fwdl-1.2.3.ebuild
index fc0248f982c3..a5db9943d66d 100644
--- a/sys-block/fwdl/fwdl-1.2.3.ebuild
+++ b/sys-block/fwdl/fwdl-1.2.3.ebuild
@@ -1,27 +1,27 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Seagate Fibre-Channel disk firmware upgrade tool"
HOMEPAGE="http://www.tc.umn.edu/~erick205/Projects/"
SRC_URI="http://www.tc.umn.edu/~erick205/Projects/${PN}/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="debug"
-src_prepare() {
- use debug || { sed -i -e "s/^EXTRA_DEFINES/#\0/" Makefile || die ; }
-}
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
-src_compile() {
- emake COMPILE_LINUX="$(tc-getCXX) ${CXXFLAGS} ${LDFLAGS}"
+src_configure() {
+ use debug && append-cppflags -DDEBUG
+ tc-export CXX
}
src_install() {
dosbin fwdl
- dodoc CHANGES INSTALL README
+ einstalldocs
}