summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/megacli')
-rw-r--r--sys-block/megacli/megacli-8.07.10.ebuild79
-rw-r--r--sys-block/megacli/megacli-8.07.14-r1.ebuild81
-rw-r--r--sys-block/megacli/megacli-8.07.14.ebuild79
3 files changed, 0 insertions, 239 deletions
diff --git a/sys-block/megacli/megacli-8.07.10.ebuild b/sys-block/megacli/megacli-8.07.10.ebuild
deleted file mode 100644
index d7705715e388..000000000000
--- a/sys-block/megacli/megacli-8.07.10.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit rpm
-MY_P=${PV}_MegaCLI_Linux
-
-DESCRIPTION="LSI Logic MegaRAID Command Line Interface management tool"
-HOMEPAGE="http://www.lsi.com/"
-SRC_URI="http://www.lsi.com/downloads/Public/RAID%20Controllers/RAID%20Controllers%20Common%20Files/${MY_P}.zip"
-
-LICENSE="LSI"
-SLOT="0"
-# This package can never enter stable, it can't be mirrored and upstream
-# can remove the distfiles from their mirror anytime.
-KEYWORDS="amd64 x86"
-IUSE=""
-
-DEPEND="app-arch/unzip
- app-admin/chrpath"
-RDEPEND="sys-libs/ncurses-compat:5"
-
-S=${WORKDIR}/${MY_P}
-
-RESTRICT="mirror fetch"
-QA_PREBUILT="/opt/${PN}/${PN}
- /opt/${PN}/lib/*"
-
-pkg_nofetch() {
- einfo "Upstream has implement a mandatory clickthrough EULA for distfile download"
- einfo "Please visit $SRC_URI"
- einfo "And place $A into your DISTDIR directory"
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- rpm_unpack ./"Linux MegaCLI ${PV}"/MegaCli-${PV}-1.noarch.rpm
-}
-
-src_install() {
- newdoc "Linux MegaCLI ${PV}.txt" RELEASE.txt
-
- exeinto /opt/megacli
- libsysfs=libstorelibir-2.so.14.07-0
- case ${ARCH} in
- amd64) MegaCli=MegaCli64;;
- x86) MegaCli=MegaCli;;
- *) die "invalid ARCH";;
- esac
- newexe opt/MegaRAID/MegaCli/${MegaCli} ${PN}
-
- exeinto /opt/${PN}/lib
- doexe opt/MegaRAID/MegaCli/${libsysfs}
-
- into /opt
- newbin "${FILESDIR}"/${PN}-wrapper ${PN}
- dosym ${PN} /opt/bin/MegaCli
-
- # Remove DT_RPATH
- chrpath -d "${D}"/opt/${PN}/${PN}
-}
-
-pkg_postinst() {
- einfo
- einfo "See /usr/share/doc/${PF}/RELEASE.txt for a list of supported controllers"
- einfo "(contains LSI model names only, not those sold by 3rd parties"
- einfo "under custom names like Dell PERC etc)."
- einfo
- einfo "As there's no dedicated manual, you might want to have"
- einfo "a look at the following cheat sheet (originally written"
- einfo "for Dell PowerEdge Expandable RAID Controllers):"
- einfo "http://tools.rapidsoft.de/perc/perc-cheat-sheet.html"
- einfo
- einfo "For more information about working with Dell PERCs see:"
- einfo "http://tools.rapidsoft.de/perc/"
- einfo
-}
diff --git a/sys-block/megacli/megacli-8.07.14-r1.ebuild b/sys-block/megacli/megacli-8.07.14-r1.ebuild
deleted file mode 100644
index 718d3ec37f96..000000000000
--- a/sys-block/megacli/megacli-8.07.14-r1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit rpm
-MY_PV="${PV//./-}"
-MY_P=${MY_PV}_MegaCLI
-
-DESCRIPTION="LSI Logic MegaRAID Command Line Interface management tool"
-# Avagotech now owns LSI
-HOMEPAGE="http://www.avagotech.com/cs/Satellite?pagename=AVG2/searchLayout&SearchKeyWord=8.07&searchType=DocumentFileExtension-zip&locale=avg_en&srchradio=within&within=8.07"
-# This file is '[zip] MegaCLI 5.5 P2', Date: 01/20/2014 Size: 7753 KB
-SRC_URI="http://docs.avagotech.com/docs-and-downloads/raid-controllers/raid-controllers-common-files/${MY_P}.zip"
-
-LICENSE="LSI"
-SLOT="0"
-# This package can never enter stable, it can't be mirrored and upstream
-# can remove the distfiles from their mirror anytime.
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="app-arch/unzip
- app-admin/chrpath"
-RDEPEND="sys-libs/ncurses-compat:5"
-
-S=${WORKDIR}
-
-# Previous releases from LSI directly required a click-through EULA; but the
-# upstream website no longer requires this consistently: most old files have
-# two or more download pages, and while one of the pages has a generic
-# click-through download form, the file-specific download page only requires
-# click-through on some items. See also sys-block/lsiutil
-RESTRICT="mirror bindist"
-QA_PREBUILT="/opt/${PN}/${PN}
- /opt/${PN}/lib/*"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- rpm_unpack ./Linux/MegaCli-${PV}-1.noarch.rpm
-}
-
-src_install() {
- newdoc "${PV}_MegaCLI.txt" RELEASE.txt
-
- exeinto /opt/megacli
- libsysfs=libstorelibir-2.so.14.07-0
- case ${ARCH} in
- amd64) MegaCli=MegaCli64;;
- x86) MegaCli=MegaCli;;
- *) die "invalid ARCH";;
- esac
- newexe opt/MegaRAID/MegaCli/${MegaCli} ${PN}
-
- exeinto /opt/${PN}/lib
- doexe opt/MegaRAID/MegaCli/${libsysfs}
-
- into /opt
- newbin "${FILESDIR}"/${PN}-wrapper ${PN}
- dosym ${PN} /opt/bin/MegaCli
-
- # Remove DT_RPATH
- chrpath -d "${D}"/opt/${PN}/${PN}
-}
-
-pkg_postinst() {
- einfo
- einfo "See /usr/share/doc/${PF}/RELEASE.txt for a list of supported controllers"
- einfo "(contains LSI model names only, not those sold by 3rd parties"
- einfo "under custom names like Dell PERC etc)."
- einfo
- einfo "As there's no dedicated manual, you might want to have"
- einfo "a look at the following cheat sheet (originally written"
- einfo "for Dell PowerEdge Expandable RAID Controllers):"
- einfo "http://tools.rapidsoft.de/perc/perc-cheat-sheet.html"
- einfo
- einfo "For more information about working with Dell PERCs see:"
- einfo "http://tools.rapidsoft.de/perc/"
- einfo
-}
diff --git a/sys-block/megacli/megacli-8.07.14.ebuild b/sys-block/megacli/megacli-8.07.14.ebuild
deleted file mode 100644
index 968ffeb5764e..000000000000
--- a/sys-block/megacli/megacli-8.07.14.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit rpm
-MY_P=${PV}_MegaCLI
-
-DESCRIPTION="LSI Logic MegaRAID Command Line Interface management tool"
-HOMEPAGE="http://www.lsi.com/"
-SRC_URI="http://www.lsi.com/downloads/Public/RAID%20Controllers/RAID%20Controllers%20Common%20Files/${MY_P}.zip"
-
-LICENSE="LSI"
-SLOT="0"
-# This package can never enter stable, it can't be mirrored and upstream
-# can remove the distfiles from their mirror anytime.
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="app-arch/unzip
- app-admin/chrpath"
-RDEPEND="sys-libs/ncurses-compat:5"
-
-S=${WORKDIR}
-
-RESTRICT="mirror fetch"
-QA_PREBUILT="/opt/${PN}/${PN}
- /opt/${PN}/lib/*"
-
-pkg_nofetch() {
- einfo "Upstream has implement a mandatory clickthrough EULA for distfile download"
- einfo "Please visit $SRC_URI"
- einfo "And place $A into your DISTDIR directory"
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- rpm_unpack ./Linux/MegaCli-${PV}-1.noarch.rpm
-}
-
-src_install() {
- newdoc "${MY_P}.txt" RELEASE.txt
-
- exeinto /opt/megacli
- libsysfs=libstorelibir-2.so.14.07-0
- case ${ARCH} in
- amd64) MegaCli=MegaCli64;;
- x86) MegaCli=MegaCli;;
- *) die "invalid ARCH";;
- esac
- newexe opt/MegaRAID/MegaCli/${MegaCli} ${PN}
-
- exeinto /opt/${PN}/lib
- doexe opt/MegaRAID/MegaCli/${libsysfs}
-
- into /opt
- newbin "${FILESDIR}"/${PN}-wrapper ${PN}
- dosym ${PN} /opt/bin/MegaCli
-
- # Remove DT_RPATH
- chrpath -d "${D}"/opt/${PN}/${PN}
-}
-
-pkg_postinst() {
- einfo
- einfo "See /usr/share/doc/${PF}/RELEASE.txt for a list of supported controllers"
- einfo "(contains LSI model names only, not those sold by 3rd parties"
- einfo "under custom names like Dell PERC etc)."
- einfo
- einfo "As there's no dedicated manual, you might want to have"
- einfo "a look at the following cheat sheet (originally written"
- einfo "for Dell PowerEdge Expandable RAID Controllers):"
- einfo "http://tools.rapidsoft.de/perc/perc-cheat-sheet.html"
- einfo
- einfo "For more information about working with Dell PERCs see:"
- einfo "http://tools.rapidsoft.de/perc/"
- einfo
-}