summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/whdd/whdd-3.0.ebuild')
-rw-r--r--sys-block/whdd/whdd-3.0.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/sys-block/whdd/whdd-3.0.ebuild b/sys-block/whdd/whdd-3.0.ebuild
index 6c4ff079329a..822e0f269d4c 100644
--- a/sys-block/whdd/whdd-3.0.ebuild
+++ b/sys-block/whdd/whdd-3.0.ebuild
@@ -7,6 +7,8 @@ EAPI=6
DESCRIPTION="Diagnostic and recovery tool for block devices"
HOMEPAGE="https://whdd.github.io"
+inherit toolchain-funcs
+
if [[ ${PV} == 9999 ]]
then
EGIT_REPO_URI="https://github.com/${PN}/${PN}"
@@ -26,3 +28,8 @@ DEPEND="
sys-libs/ncurses:0=[unicode]"
RDEPEND="${DEPEND}
sys-apps/smartmontools"
+
+src_compile() {
+ tc-export CC
+ default
+}