summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/arcconf/Manifest1
-rw-r--r--sys-block/arcconf/arcconf-4.14.00.26064.ebuild36
-rw-r--r--sys-block/di/di-4.52.ebuild2
-rw-r--r--sys-block/f3/f3-8.0-r1.ebuild2
-rw-r--r--sys-block/hpacucli/hpacucli-9.40.12.0.ebuild5
-rw-r--r--sys-block/hpssacli/hpssacli-2.40.13.0-r1.ebuild5
-rw-r--r--sys-block/hpssacli/hpssacli-3.40.3.0.ebuild5
-rw-r--r--sys-block/hpssacli/hpssacli-4.21.7.0.ebuild3
-rw-r--r--sys-block/hpssacli/hpssacli-5.30.6.0.ebuild3
-rw-r--r--sys-block/hpssacli/hpssacli-6.10.14.0.ebuild3
-rw-r--r--sys-block/mbuffer/mbuffer-20230301.ebuild2
-rw-r--r--sys-block/nbdkit/Manifest1
-rw-r--r--sys-block/nbdkit/metadata.xml1
-rw-r--r--sys-block/nbdkit/nbdkit-1.32.4.ebuild1
-rw-r--r--sys-block/nbdkit/nbdkit-1.36.1.ebuild120
-rw-r--r--sys-block/parted/files/parted-3.6-underlinked-util-linux.patch26
-rw-r--r--sys-block/parted/parted-3.6-r1.ebuild82
-rw-r--r--sys-block/parted/parted-3.6.ebuild2
-rw-r--r--sys-block/partitionmanager/Manifest2
-rw-r--r--sys-block/partitionmanager/partitionmanager-23.08.3.ebuild (renamed from sys-block/partitionmanager/partitionmanager-23.08.1.ebuild)2
-rw-r--r--sys-block/perccli/Manifest2
-rw-r--r--sys-block/perccli/perccli-7.2313.0.ebuild55
-rw-r--r--sys-block/tgt/Manifest3
-rw-r--r--sys-block/tgt/files/tgtd.initd-new2
-rw-r--r--sys-block/tgt/tgt-1.0.87-r2.ebuild (renamed from sys-block/tgt/tgt-1.0.87-r1.ebuild)0
-rw-r--r--sys-block/tgt/tgt-1.0.88-r1.ebuild (renamed from sys-block/tgt/tgt-1.0.86.ebuild)9
-rw-r--r--sys-block/tgt/tgt-1.0.89.ebuild (renamed from sys-block/tgt/tgt-1.0.87.ebuild)9
-rw-r--r--sys-block/thin-provisioning-tools/thin-provisioning-tools-1.0.6.ebuild2
-rw-r--r--sys-block/wait-for-dri-devices-rules/Manifest1
-rw-r--r--sys-block/wait-for-dri-devices-rules/metadata.xml10
-rw-r--r--sys-block/wait-for-dri-devices-rules/wait-for-dri-devices-rules-1.ebuild43
31 files changed, 406 insertions, 34 deletions
diff --git a/sys-block/arcconf/Manifest b/sys-block/arcconf/Manifest
index 9b0dd4fcdf24..9826302213cd 100644
--- a/sys-block/arcconf/Manifest
+++ b/sys-block/arcconf/Manifest
@@ -1,2 +1,3 @@
DIST arcconf_B25823.zip 86931369 BLAKE2B c11eb498474cdd13d15bf1516ada423d4d1b71c538f346f854a30d3645e8e7db996d8f934a66c55fcb6b4397982de43e2d84b9aebfcc2de2922b950bcfc4c8fb SHA512 da5396c43783636013fb88137f45638ece2767d9e5649577136be123cee5c6eededfac464b965c0474bae65db18147c696f9b30274045c61788669cc56307718
+DIST arcconf_B26064.zip 40927172 BLAKE2B 1d9524ff4a4307b565c23c8ceebba95fa6882d62274dbfda7bf3431d370ee635a54811458e0d34f875827059339036bc35c5cf1687e5e96e4a2a8442ebf166a0 SHA512 4d91aa85089c31751ca6f39eb5562d68006703f88deb5bc86fa4a15735cfa9ff8b51b4b204f80d8b4bfe35fdd18565e111764674d1c2c7253e78b411836c4b71
DIST arcconf_v2_01_22270.zip 47168976 BLAKE2B 95693a1408e5a4d0d638bbf265f2e1e64247dfec2b1078b56860c5fcd4b13ffa5967bfb9967abfd4b79c788aaeb20759b3a9070a84b083c1653e4868a96ac4cf SHA512 0f91a697c44ea0c0561bec9e432e7d4eba8eb8a2b0255a9867bdb183f81e745aee1dcc2b0017847803dbb27f55cad3e985f4bcd3a202c52f5b557fb724e94d9e
diff --git a/sys-block/arcconf/arcconf-4.14.00.26064.ebuild b/sys-block/arcconf/arcconf-4.14.00.26064.ebuild
new file mode 100644
index 000000000000..6f79502767cc
--- /dev/null
+++ b/sys-block/arcconf/arcconf-4.14.00.26064.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="B$(ver_cut 4)"
+
+inherit linux-info
+
+DESCRIPTION="Microsemi Adaptec RAID Controller Command Line Utility"
+HOMEPAGE="https://www.microsemi.com/"
+SRC_URI="http://download.adaptec.com/raid/storage_manager/${PN}_${MY_PV}.zip"
+S="${WORKDIR}/linux"
+
+LICENSE="Microsemi"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm64"
+
+BDEPEND="app-arch/unzip"
+
+RESTRICT="mirror bindist"
+
+QA_PREBUILT="usr/bin/arcconf"
+
+pkg_setup() {
+ # CONFIG_HARDENED_USERCOPY_PAGESPAN makes ARCCONF segault
+ # LEGACY_VSYSCALL_NONE makes ARCCONF segaultmakes ARCCONF segault
+ if linux-info_get_any_version && linux_config_src_exists; then
+ CONFIG_CHECK="!HARDENED_USERCOPY_PAGESPAN !LEGACY_VSYSCALL_NONE"
+ check_extra_config
+ fi
+}
+
+src_install() {
+ dobin $(usex arm64 'arm/linuxarm_x64/cmdline/' '')arcconf
+}
diff --git a/sys-block/di/di-4.52.ebuild b/sys-block/di/di-4.52.ebuild
index fa7564c447bb..074ac2459798 100644
--- a/sys-block/di/di-4.52.ebuild
+++ b/sys-block/di/di-4.52.ebuild
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/diskinfo-di/${P}.tar.gz"
LICENSE="ZLIB"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+KEYWORDS="amd64 ppc ppc64 x86"
IUSE="nls"
RESTRICT="test" #405205, #405471
diff --git a/sys-block/f3/f3-8.0-r1.ebuild b/sys-block/f3/f3-8.0-r1.ebuild
index 69e189a0304e..f4569914ae13 100644
--- a/sys-block/f3/f3-8.0-r1.ebuild
+++ b/sys-block/f3/f3-8.0-r1.ebuild
@@ -13,7 +13,7 @@ if [[ ${PV} == "9999" ]]; then
inherit git-r3
else
SRC_URI="https://github.com/AltraMayor/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ KEYWORDS="amd64 ~arm ~arm64 x86"
fi
LICENSE="GPL-3+"
diff --git a/sys-block/hpacucli/hpacucli-9.40.12.0.ebuild b/sys-block/hpacucli/hpacucli-9.40.12.0.ebuild
index c2418f407ee1..887a5e423e08 100644
--- a/sys-block/hpacucli/hpacucli-9.40.12.0.ebuild
+++ b/sys-block/hpacucli/hpacucli-9.40.12.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -22,9 +22,8 @@ SRC_URI="
LICENSE="hp-proliant-essentials"
SLOT="0"
KEYWORDS="-* amd64 x86"
-IUSE=""
+RESTRICT="mirror bindist"
-DEPEND=""
RDEPEND="sys-apps/coreutils
sys-process/procps
>=sys-apps/util-linux-2.20.1"
diff --git a/sys-block/hpssacli/hpssacli-2.40.13.0-r1.ebuild b/sys-block/hpssacli/hpssacli-2.40.13.0-r1.ebuild
index 6835fe61bd18..d7ad49235f50 100644
--- a/sys-block/hpssacli/hpssacli-2.40.13.0-r1.ebuild
+++ b/sys-block/hpssacli/hpssacli-2.40.13.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,9 +16,8 @@ SRC_URI="
LICENSE="hpe"
SLOT="0"
KEYWORDS="-* amd64 x86"
-IUSE=""
+RESTRICT="mirror bindist"
-DEPEND=""
RDEPEND="elibc_glibc? ( >sys-libs/glibc-2.14 )
>=sys-libs/libunwind-0.99
>=sys-process/procps-3.3.6"
diff --git a/sys-block/hpssacli/hpssacli-3.40.3.0.ebuild b/sys-block/hpssacli/hpssacli-3.40.3.0.ebuild
index 7256e45a562c..9c1a449f982c 100644
--- a/sys-block/hpssacli/hpssacli-3.40.3.0.ebuild
+++ b/sys-block/hpssacli/hpssacli-3.40.3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -14,9 +14,8 @@ SRC_URI="https://downloads.linux.hpe.com/SDR/repo/spp/2019.03.0/packages/ssacli-
LICENSE="hpe"
SLOT="0"
KEYWORDS="-* amd64"
-IUSE=""
+RESTRICT="mirror bindist"
-DEPEND=""
RDEPEND="
elibc_glibc? ( sys-libs/glibc )
sys-libs/libunwind
diff --git a/sys-block/hpssacli/hpssacli-4.21.7.0.ebuild b/sys-block/hpssacli/hpssacli-4.21.7.0.ebuild
index 52b203ce7f2d..cd9dca11df25 100644
--- a/sys-block/hpssacli/hpssacli-4.21.7.0.ebuild
+++ b/sys-block/hpssacli/hpssacli-4.21.7.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -14,6 +14,7 @@ SRC_URI="https://downloads.hpe.com/pub/softlib2/software1/pubsw-linux/p185704664
LICENSE="hp-proliant-essentials"
SLOT="0"
KEYWORDS="-* amd64"
+RESTRICT="mirror bindist"
S="${WORKDIR}"
diff --git a/sys-block/hpssacli/hpssacli-5.30.6.0.ebuild b/sys-block/hpssacli/hpssacli-5.30.6.0.ebuild
index faecf2d242c6..42487d33f1d1 100644
--- a/sys-block/hpssacli/hpssacli-5.30.6.0.ebuild
+++ b/sys-block/hpssacli/hpssacli-5.30.6.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -14,6 +14,7 @@ SRC_URI="https://downloads.hpe.com/pub/softlib2/software1/pubsw-linux/p173609780
LICENSE="hp-proliant-essentials"
SLOT="0"
KEYWORDS="-* amd64"
+RESTRICT="mirror bindist"
S="${WORKDIR}"
diff --git a/sys-block/hpssacli/hpssacli-6.10.14.0.ebuild b/sys-block/hpssacli/hpssacli-6.10.14.0.ebuild
index 45a073f0681d..81e16799dfcb 100644
--- a/sys-block/hpssacli/hpssacli-6.10.14.0.ebuild
+++ b/sys-block/hpssacli/hpssacli-6.10.14.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -14,6 +14,7 @@ SRC_URI="https://downloads.hpe.com/pub/softlib2/software1/pubsw-linux/p173609780
LICENSE="hp-proliant-essentials"
SLOT="0"
KEYWORDS="-* amd64"
+RESTRICT="mirror bindist"
S="${WORKDIR}"
diff --git a/sys-block/mbuffer/mbuffer-20230301.ebuild b/sys-block/mbuffer/mbuffer-20230301.ebuild
index e7e12553a571..263be763e8bf 100644
--- a/sys-block/mbuffer/mbuffer-20230301.ebuild
+++ b/sys-block/mbuffer/mbuffer-20230301.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://www.maier-komor.de/software/mbuffer/${P}.tgz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ~riscv x86"
+KEYWORDS="amd64 arm arm64 ppc ~riscv ~sparc x86"
IUSE="debug ssl test"
REQUIRED_USE="test? ( ssl )"
RESTRICT="!test? ( test )"
diff --git a/sys-block/nbdkit/Manifest b/sys-block/nbdkit/Manifest
index a15cca17ca1c..60eb811e64f5 100644
--- a/sys-block/nbdkit/Manifest
+++ b/sys-block/nbdkit/Manifest
@@ -1 +1,2 @@
DIST nbdkit-1.32.4.tar.gz 2342420 BLAKE2B 3ea6692a534548707bc488560b0f0bd0ddeb0daa4b2432da5de18a9a735408370c61b8c0a30d7d4ed6c915eb118948d2462ff4565036bec8a77c2c2fb712f4da SHA512 0eb1f0f492ce3558fba8d472b26f7ca3db7beeba411c98e7e06b55c5456399be56f6b4cd4adb54567f744f8e07986af9f676a983da052d174ce2e3c28109dbc5
+DIST nbdkit-1.36.1.tar.gz 2400838 BLAKE2B afbfbda18122b17cbcdcc5b3a04ab37b7dffb139d084b196ef45e33717f376af61189beb63b2541444eaae0ed860b752c20cfe9cf27bf06bfb04bba1b5ce60c8 SHA512 ca0e6e6729fb6f43a9717a3815dfb8ff54a2f182ef079e72b0e5e1b018c55f2205be52a10abc0b0a2243d0737f27b1ccf67c0d9586135454a460d39dad79f042
diff --git a/sys-block/nbdkit/metadata.xml b/sys-block/nbdkit/metadata.xml
index fef0d9dee6e7..ba85f17afedd 100644
--- a/sys-block/nbdkit/metadata.xml
+++ b/sys-block/nbdkit/metadata.xml
@@ -16,5 +16,6 @@
<flag name="libvirt">Enable the <pkg>app-emulation/libvirt</pkg> plugin.</flag>
<flag name="nbd">Enable the nbd plugin via <pkg>sys-libs/libnbd</pkg>.</flag>
<flag name="torrent">Enable the torrent plugin via <pkg>net-libs/libtorrent-rasterbar</pkg>.</flag>
+ <flag name="zlib-ng">Use <pkg>sys-libs/zlib-ng</pkg> to handle zlib decompression.</flag>
</use>
</pkgmetadata>
diff --git a/sys-block/nbdkit/nbdkit-1.32.4.ebuild b/sys-block/nbdkit/nbdkit-1.32.4.ebuild
index 65b7b4cfa153..556001f72a78 100644
--- a/sys-block/nbdkit/nbdkit-1.32.4.ebuild
+++ b/sys-block/nbdkit/nbdkit-1.32.4.ebuild
@@ -3,7 +3,6 @@
EAPI=8
-WANT_LIBTOOL=none
inherit autotools optfeature
DESCRIPTION="NBD server with stable plugin ABI and permissive license"
diff --git a/sys-block/nbdkit/nbdkit-1.36.1.ebuild b/sys-block/nbdkit/nbdkit-1.36.1.ebuild
new file mode 100644
index 000000000000..34ea8cc1967c
--- /dev/null
+++ b/sys-block/nbdkit/nbdkit-1.36.1.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools optfeature bash-completion-r1
+
+DESCRIPTION="NBD server with stable plugin ABI and permissive license"
+HOMEPAGE="https://gitlab.com/nbdkit/nbdkit"
+SRC_URI="https://download.libguestfs.org/nbdkit/$(ver_cut 1-2)-stable/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="
+ curl ext2 nbd gnutls libguestfs libssh libvirt lzma selinux torrent
+ valgrind zlib zlib-ng zstd
+"
+
+RDEPEND="
+ virtual/libiconv
+ selinux? ( sys-libs/libselinux )
+ gnutls? ( net-libs/gnutls:= )
+ curl? ( net-misc/curl )
+ libssh? ( net-libs/libssh:= )
+ libvirt? ( app-emulation/libvirt:= )
+ zlib? ( sys-libs/zlib )
+ zlib-ng? ( sys-libs/zlib-ng )
+ nbd? ( sys-libs/libnbd )
+ lzma? ( app-arch/xz-utils )
+ zstd? ( app-arch/zstd:= )
+ libguestfs? ( app-emulation/libguestfs:= )
+ ext2? ( sys-fs/e2fsprogs )
+ torrent? ( net-libs/libtorrent-rasterbar:= )
+"
+DEPEND="
+ ${RDEPEND}
+ valgrind? ( dev-util/valgrind )
+"
+BDEPEND="
+ dev-lang/perl
+"
+
+src_prepare() {
+ default
+
+ # TODO(arsen): This test fails for some reason.
+ cat <<-HACK > tests/test-file-extents.sh || die
+ #!/bin/sh
+ echo Gentoo: This test is skipped
+ exit 77
+ HACK
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-extra=Gentoo
+
+ --with-iconv
+ --with-manpages
+
+ $(use_with selinux)
+ $(use_with gnutls)
+ $(use_with curl)
+ $(use_with libvirt)
+ $(use_with zlib)
+ $(use_with zlib-ng)
+ $(use_with nbd libnbd)
+ $(use_with lzma liblzma)
+ $(use_with zstd libzstd)
+ $(use_with libguestfs)
+ $(use_with ext2)
+ $(use_enable torrent)
+ $(use_enable valgrind)
+
+ --disable-linuxdisk # Not in Gentoo.
+ --disable-libfuzzer # Should not be used normally according to upstream
+ --without-libblkio # Not in Gentoo.
+ --without-bash-completions # Handled manually.
+
+ # TODO(arsen): Bindings left out
+ --disable-perl
+ --disable-python
+ --disable-ocaml
+ --disable-rust
+ --disable-ruby
+ --disable-tcl
+ --disable-lua
+ --disable-golang
+
+ # This just enabled a few code paths with no extra library
+ # dependencies, but it does have an extra xorriso runtime
+ # dependency. Seeing as it's optional, and it conflates BDEPEND
+ # and RDEPEND; I think it's okay to just specify that it uses
+ # XORRISO installed as xorriso. Maybe the user should be able
+ # to override this in the future if they prefer one of the other
+ # ISOPROGs?
+ --with-iso
+ ac_cv_prog_XORRISO=xorriso
+
+ # Involves proprietary code and a dlopen mess, see
+ # plugins/vddk/README.VDDK.
+ --disable-vddk
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+ dobashcomp bash-completion/nbdkit
+}
+
+pkg_postinst() {
+ optfeature "virtual ISO plugin via xorriso" dev-libs/libisoburn
+}
diff --git a/sys-block/parted/files/parted-3.6-underlinked-util-linux.patch b/sys-block/parted/files/parted-3.6-underlinked-util-linux.patch
new file mode 100644
index 000000000000..6e02f4aac8d8
--- /dev/null
+++ b/sys-block/parted/files/parted-3.6-underlinked-util-linux.patch
@@ -0,0 +1,26 @@
+https://bugs.gentoo.org/910487
+https://git.savannah.gnu.org/cgit/parted.git/commit/?id=d22c2d01f62139e0d386d90584cac0705857a571
+
+From d22c2d01f62139e0d386d90584cac0705857a571 Mon Sep 17 00:00:00 2001
+From: Yegor Yefremov <yegorslists@googlemail.com>
+Date: Thu, 11 May 2023 10:03:59 +0200
+Subject: parted: link to libuuid
+
+parted.c uses libuuid since 61b3a9733c0e0a79ccc43096642d378c8706add6.
+Hence, add UUID_LIBS to PARTED_LIBS to avoid
+"DSO missing from command line" error.
+
+Signed-off-by: Brian C. Lane <bcl@redhat.com>
+--- a/configure.ac
++++ b/configure.ac
+@@ -298,6 +298,8 @@ Note: originally, libuuid was part of the e2fsprogs package. Later, it
+ moved to util-linux-ng-2.16, and that package is now the preferred source.])])
+ AC_SUBST([UUID_LIBS])
+
++PARTED_LIBS="$PARTED_LIBS $UUID_LIBS"
++
+ dnl Check for libdevmapper
+ DM_LIBS=
+ if test $ENABLE_DEVICE_MAPPER = yes; then
+--
+cgit v1.1
diff --git a/sys-block/parted/parted-3.6-r1.ebuild b/sys-block/parted/parted-3.6-r1.ebuild
new file mode 100644
index 000000000000..fc9c2c6651cb
--- /dev/null
+++ b/sys-block/parted/parted-3.6-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/bcl.asc
+
+inherit autotools verify-sig
+
+DESCRIPTION="Create, destroy, resize, check, copy partitions and file systems"
+HOMEPAGE="https://www.gnu.org/software/parted/"
+SRC_URI="
+ mirror://gnu/${PN}/${P}.tar.xz
+ verify-sig? ( mirror://gnu/${PN}/${P}.tar.xz.sig )
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+debug device-mapper nls readline"
+
+# util-linux for libuuid
+RDEPEND="
+ >=sys-fs/e2fsprogs-1.27
+ sys-apps/util-linux
+ device-mapper? ( >=sys-fs/lvm2-2.02.45 )
+ readline? (
+ >=sys-libs/ncurses-5.7-r7:0=
+ >=sys-libs/readline-5.2:0=
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ nls? ( >=sys-devel/gettext-0.12.1-r2 )
+ verify-sig? ( >=sec-keys/openpgp-keys-bcl-20230315 )
+ virtual/pkgconfig
+"
+
+DOCS=(
+ AUTHORS BUGS ChangeLog NEWS README THANKS TODO doc/{API,FAT,USER.jp}
+)
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.2-po4a-mandir.patch
+ "${FILESDIR}"/${PN}-3.3-atari.patch
+ # https://lists.gnu.org/archive/html/bug-parted/2022-02/msg00000.html
+ "${FILESDIR}"/${PN}-3.4-posix-printf.patch
+ # https://debbugs.gnu.org/61129
+ "${FILESDIR}"/${PN}-3.6-tests-unicode.patch
+ # https://debbugs.gnu.org/61128
+ "${FILESDIR}"/${PN}-3.6-tests-non-bash.patch
+ # bug #910487
+ "${FILESDIR}"/${P}-underlinked-util-linux.patch
+)
+
+# false positive
+QA_CONFIG_IMPL_DECL_SKIP="MIN"
+
+src_prepare() {
+ default
+ eautoreconf
+
+ touch doc/pt_BR/Makefile.in || die
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable debug)
+ $(use_enable device-mapper)
+ $(use_enable nls)
+ $(use_with readline)
+ --disable-rpath
+ --disable-static
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}
diff --git a/sys-block/parted/parted-3.6.ebuild b/sys-block/parted/parted-3.6.ebuild
index e70d45603592..98822373ddb2 100644
--- a/sys-block/parted/parted-3.6.ebuild
+++ b/sys-block/parted/parted-3.6.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/bcl.asc
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/bcl.asc
inherit autotools verify-sig
diff --git a/sys-block/partitionmanager/Manifest b/sys-block/partitionmanager/Manifest
index 577159b0e55e..b438e9853069 100644
--- a/sys-block/partitionmanager/Manifest
+++ b/sys-block/partitionmanager/Manifest
@@ -1,2 +1,2 @@
DIST partitionmanager-23.04.3.tar.xz 2143336 BLAKE2B 79208e759ada12a45a1d8b56bc1127e0f8a294acc0baac617a6990dcb13c4c3544dc362490fda5620cb66ab052b01a4c436079e653bbc94b3304e552feab4f34 SHA512 29a2af3beb0189ff7a5f54aca393834b185dcbc538ac3ad0319198d59e239394cf8c54479d3596f246e6bc18682c03155896b41ccb0cf434bd8f1e43aeda42b7
-DIST partitionmanager-23.08.1.tar.xz 2147856 BLAKE2B 6f6ec9fe8e666b278a2261cd4354a5c5da399d3448b74d6ac3210f182157ccdafe04bc7ea918bc036d85c4f06e2d149efb03f1529e80c374f76a4abe50516d15 SHA512 565033aca4acb924937d18c10ec777cda3a6da724aacd658808385da9d62f32b33547f824885dbc3890e1c426cc9573cc9962dc5b3574a6588ab992c3b05ede7
+DIST partitionmanager-23.08.3.tar.xz 2147812 BLAKE2B 595deda9d654af0c319d2e092d7c690dd2a53071ac37007dcd0199fee16d9e40b16fd64dc429bc84b334a3622b3171c36427bbfdc8e3316fbd75e696f6693ee0 SHA512 61c97abde57f197fc60751e43ac58427f5e86afc21b426582b538d92804bd8d9f6817ac9021bdff183744b8ae229e75a02966217bc8176cef3440a56ba6b00ae
diff --git a/sys-block/partitionmanager/partitionmanager-23.08.1.ebuild b/sys-block/partitionmanager/partitionmanager-23.08.3.ebuild
index 5603899adfa7..03f161e486e4 100644
--- a/sys-block/partitionmanager/partitionmanager-23.08.1.ebuild
+++ b/sys-block/partitionmanager/partitionmanager-23.08.3.ebuild
@@ -14,7 +14,7 @@ HOMEPAGE="https://apps.kde.org/partitionmanager/"
LICENSE="GPL-3"
SLOT="5"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~x86"
+KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 x86"
IUSE=""
DEPEND="
diff --git a/sys-block/perccli/Manifest b/sys-block/perccli/Manifest
index 9d2ad7a901ab..37a20f01855e 100644
--- a/sys-block/perccli/Manifest
+++ b/sys-block/perccli/Manifest
@@ -1,2 +1,4 @@
+DIST PERCCLI_7.2313.0_A14_Linux.tar.gz 4690834 BLAKE2B 9c197a4cdb3305b7c7228506dc96ea943308c442a770be8aae08c9ff6c92396a73b7ffac227967bd6330f2fa1b7c12c886984bd01405f9326e17e067adbef1b9 SHA512 640a31c774f67250a4001e427ed6934d8d9b87be97aa20ab9ecb2e19211e4adb1c09a0266af6f2894fcbe03c2b68b965e9d288c10cab7606c3f4ac766386f0c5
DIST dell-sas-hba-12gbps_reference-guide_en-us.pdf 450398 BLAKE2B b97ef640b53fb631ac4d9478f621709d7dad1d19786b8fcd96adcaef3ae8a13ca449f0b5d63b29e36c0a10a30b187164cc2a538836f95c6c0c669f31c9443b2f SHA512 17be31c01d350ca28434ded58599f1de8ca93770fcc52da107d8639d93145397ba5b43931c86020093de9eaec092f8bb6a4c401a2d98bdc7ec465e947b462a3d
+DIST perccli-7.2313.0.efi 14427392 BLAKE2B 1407fd682982604ee2c602fd70ea577fefec729751c561534d7141204c36fddad2113e78913e840d75cde2d62905caa6761b68cb98d2d3247e0da103f7b93233 SHA512 6f1f3f5e027202720336784de4482b092b537ba0d0c34a364886fd39c7ab3393ddaf2ba5b966d73e8c3735e89abfa747d53189182547794c73b2eef3a5d15c7c
DIST perccli_linux_NF8G9_A07_7.529.00.tar.gz 6624840 BLAKE2B 29b67d8807bc12b2c4d3df880176209ba9c44f48d74367172d1d673070ece435537158c5998fc79eb68c33ec3eb2009e55e333f88419c23f911af091e6ccf371 SHA512 71e44772d291fa2d9529ab10917a3841395fe16daa66a2d64d1e120d5c3d43ce34479a5217fc1fbe7f4772b92fccc673fe387cb2e9a7683c9b5a3e26a348713c
diff --git a/sys-block/perccli/perccli-7.2313.0.ebuild b/sys-block/perccli/perccli-7.2313.0.ebuild
new file mode 100644
index 000000000000..b60f35fc2ab6
--- /dev/null
+++ b/sys-block/perccli/perccli-7.2313.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit mount-boot rpm secureboot
+
+DESCRIPTION="LINUX PERCCLI Utility For All Dell HBA/PERC Controllers"
+HOMEPAGE="https://www.dell.com/support/home/en-us/drivers/driversdetails?driverid=tdghn"
+LICENSE="Dell-EULA"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="efi"
+RESTRICT="bindist fetch mirror strip"
+DEPEND=""
+RDEPEND=""
+QA_PREBUILT="opt/MegaRAID/perccli/perccli* boot/efi/perccli.efi"
+
+# Files not fetchable with the default user-agent, and EULA
+# requires consent for redistribution.
+SRC_URI="https://dl.dell.com/FOLDER09770976M/1/PERCCLI_7.2313.0_A14_Linux.tar.gz
+ efi? ( https://dl.dell.com/FOLDER09770794M/1/perccli.efi -> perccli-7.2313.0.efi )"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo "Please download PERCCLI_7.2313.0_A14_Linux.tar.gz from"
+ einfo "${HOMEPAGE}"
+ einfo "and place the file in your DISTDIR directory."
+ if use efi; then
+ einfo "Please download perccli.efi from"
+ einfo "${HOMEPAGE}"
+ einfo "and rename the file to perccli-7.2313.0.efi and place it in your DISTDIR directory."
+ fi
+}
+
+pkg_setup() {
+ use efi && secureboot_pkg_setup
+}
+
+src_unpack() {
+ default
+ rpm_unpack ./PERCCLI*Linux/*.rpm
+}
+
+src_install() {
+ exeinto /opt/MegaRAID/perccli
+ doexe opt/MegaRAID/perccli/perccli64 && \
+ dosym perccli64 /opt/MegaRAID/perccli/perccli
+ dosym ../MegaRAID/perccli/perccli /opt/bin/perccli
+ if use efi; then
+ exeinto /boot/efi
+ newexe "${DISTDIR}/perccli-7.2313.0.efi" perccli.efi
+ fi
+ use efi && secureboot_auto_sign --in-place
+}
diff --git a/sys-block/tgt/Manifest b/sys-block/tgt/Manifest
index 4acb98a49afa..7ce9f61c5895 100644
--- a/sys-block/tgt/Manifest
+++ b/sys-block/tgt/Manifest
@@ -1,2 +1,3 @@
-DIST tgt-1.0.86.tar.gz 304697 BLAKE2B 60233019e9f09dd4288ca70f398992452dc00f7a2f46d82e333a9e1bfa4fe5dcc8583da3d4ce4382b32c60b1b009dd03d36faa9770faa11222b9ec4592bd6d96 SHA512 f4e8e87691be2793c5eee9d7dc744ae3a7b47f710f559141f0533de345f727fb68223a3090282f5c51f70ea55fbf5936d81e3b08ce953b7ac48013295c32bef7
DIST tgt-1.0.87.tar.gz 304798 BLAKE2B e8772a02078204373dd43276cc5534dd9e8996841bdfef613f34a9c59ef2886f866ff6fb56e6bdaea653b4081b477e1ab15cb3ed3d125b7c08b45ab11a63a7cb SHA512 362adfc92f9fc6528b3de0aa9f202e39f6035b92fe3078236a3f75c0aef540a82cb4594077fdc7de2e524acc75601f5696111cc9aebc6de6265c53cd1d073db2
+DIST tgt-1.0.88.tar.gz 305767 BLAKE2B d9a35da5c12ba1621473a04f59ffc85364412443854e4b9d88ba7ae7a7120dbbf6cf233852ef33cca2f19bb67acd54dcdd97041812277cc7eb9359d2483289d4 SHA512 b1ac4da634ff65edfd67cfcbd4509772216ba411b8c389cd209d3abe7c72b19f8e261c627e3ad8343faeebe3d8b758855184b50ab9e635d11c707ba3bb79fe70
+DIST tgt-1.0.89.tar.gz 305773 BLAKE2B c128e307246c938ee9b41fa9d0783cfa488e103f38c8907768bc46ec46dfc6fa7b8aad5e14f43dfd111a5b6590b41ce6cf77683c2dc123ab5917f89e7c3d951c SHA512 4a3f2e1e2a9e98fbb6892fb8171633efd15ce131f0e9294d95a7d8b23b6df739f11529e50ed03869d65a8a84a57f7337901f36e010a770a051caaa7ba2b47e7a
diff --git a/sys-block/tgt/files/tgtd.initd-new b/sys-block/tgt/files/tgtd.initd-new
index 7941f1a7e974..962ed7bd3a2a 100644
--- a/sys-block/tgt/files/tgtd.initd-new
+++ b/sys-block/tgt/files/tgtd.initd-new
@@ -9,7 +9,7 @@
pidfile="/var/run/${RC_SVCNAME}.pid"
command="/usr/sbin/tgtd"
-command_args_background="--pid-file ${pidfile}"
+command_args_background="--pid-file ${pidfile} ${tgtd_opts}"
extra_commands="forcedstop"
extra_started_commands="forcedreload reload"
diff --git a/sys-block/tgt/tgt-1.0.87-r1.ebuild b/sys-block/tgt/tgt-1.0.87-r2.ebuild
index f5b5df98b0fe..f5b5df98b0fe 100644
--- a/sys-block/tgt/tgt-1.0.87-r1.ebuild
+++ b/sys-block/tgt/tgt-1.0.87-r2.ebuild
diff --git a/sys-block/tgt/tgt-1.0.86.ebuild b/sys-block/tgt/tgt-1.0.88-r1.ebuild
index 32b714b14d91..3acece87b340 100644
--- a/sys-block/tgt/tgt-1.0.86.ebuild
+++ b/sys-block/tgt/tgt-1.0.88-r1.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/fujita/tgt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm64 ~hppa ~ia64 ~loong ~ppc ppc64 ~riscv ~sparc x86"
-IUSE="fcoe fcp ibmvio infiniband rbd selinux"
+IUSE="infiniband rbd selinux"
DEPEND="
app-text/docbook-xsl-stylesheets
@@ -41,10 +41,7 @@ src_prepare() {
src_compile() {
local myconf
- use ibmvio && myconf="${myconf} IBMVIO=1"
use infiniband && myconf="${myconf} ISCSI_RDMA=1"
- use fcp && myconf="${myconf} FCP=1"
- use fcoe && myconf="${myconf} FCOE=1"
use rbd && myconf="${myconf} CEPH_RBD=1"
emake -C usr/ KERNELSRC="${KERNEL_DIR}" ISCSI=1 ${myconf}
@@ -53,8 +50,8 @@ src_compile() {
src_install() {
emake install-programs install-scripts install-doc DESTDIR="${D}" docdir=/usr/share/doc/${PF}
- newinitd "${FILESDIR}"/tgtd.initd tgtd
- newconfd "${FILESDIR}"/tgtd.confd tgtd
+ newinitd "${FILESDIR}"/tgtd.initd-new tgtd
+ newconfd "${FILESDIR}"/tgtd.confd-new tgtd
systemd_dounit "${S}"/scripts/tgtd.service
dodir /etc/tgt
keepdir /etc/tgt
diff --git a/sys-block/tgt/tgt-1.0.87.ebuild b/sys-block/tgt/tgt-1.0.89.ebuild
index fae52eca55dc..afca5f425e44 100644
--- a/sys-block/tgt/tgt-1.0.87.ebuild
+++ b/sys-block/tgt/tgt-1.0.89.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/fujita/tgt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
-IUSE="fcoe fcp ibmvio infiniband rbd selinux"
+IUSE="infiniband rbd selinux"
DEPEND="
app-text/docbook-xsl-stylesheets
@@ -41,10 +41,7 @@ src_prepare() {
src_compile() {
local myconf
- use ibmvio && myconf="${myconf} IBMVIO=1"
use infiniband && myconf="${myconf} ISCSI_RDMA=1"
- use fcp && myconf="${myconf} FCP=1"
- use fcoe && myconf="${myconf} FCOE=1"
use rbd && myconf="${myconf} CEPH_RBD=1"
emake -C usr/ KERNELSRC="${KERNEL_DIR}" ISCSI=1 ${myconf}
@@ -53,8 +50,8 @@ src_compile() {
src_install() {
emake install-programs install-scripts install-doc DESTDIR="${D}" docdir=/usr/share/doc/${PF}
- newinitd "${FILESDIR}"/tgtd.initd tgtd
- newconfd "${FILESDIR}"/tgtd.confd tgtd
+ newinitd "${FILESDIR}"/tgtd.initd-new tgtd
+ newconfd "${FILESDIR}"/tgtd.confd-new tgtd
systemd_dounit "${S}"/scripts/tgtd.service
dodir /etc/tgt
keepdir /etc/tgt
diff --git a/sys-block/thin-provisioning-tools/thin-provisioning-tools-1.0.6.ebuild b/sys-block/thin-provisioning-tools/thin-provisioning-tools-1.0.6.ebuild
index 698928f72ffd..9dd27580edda 100644
--- a/sys-block/thin-provisioning-tools/thin-provisioning-tools-1.0.6.ebuild
+++ b/sys-block/thin-provisioning-tools/thin-provisioning-tools-1.0.6.ebuild
@@ -146,7 +146,7 @@ else
https://github.com/jthornber/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
${CARGO_CRATE_URIS}
"
- KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="~amd64 arm arm64 ~loong ~mips ppc64 ~riscv x86 ~amd64-linux ~x86-linux"
fi
LICENSE="Apache-2.0 BSD GPL-3 MIT Unicode-DFS-2016"
diff --git a/sys-block/wait-for-dri-devices-rules/Manifest b/sys-block/wait-for-dri-devices-rules/Manifest
new file mode 100644
index 000000000000..4f046c13b95f
--- /dev/null
+++ b/sys-block/wait-for-dri-devices-rules/Manifest
@@ -0,0 +1 @@
+DIST wait-for-dri-devices-rules-1.tar.bz2 6995 BLAKE2B 0cd257c1223844948040728be2ceef53b71007e6d87d23c7c6f697f125ca89432d7bfe4011605dc2dec9185091f777c1205233cfd425471c7b2bc25f65bf79b3 SHA512 51149b8d604a97eb531452b17c1290779ced8ec300c615e89accfb80522287d53c47177c0aee58714686fc9c1c0544e865611d09634d5b8f7ee3e542d74d3f9d
diff --git a/sys-block/wait-for-dri-devices-rules/metadata.xml b/sys-block/wait-for-dri-devices-rules/metadata.xml
new file mode 100644
index 000000000000..c288b0ec6a5f
--- /dev/null
+++ b/sys-block/wait-for-dri-devices-rules/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>pacho@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="gitlab">pachoramos/wait-for-dri-devices-rules</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-block/wait-for-dri-devices-rules/wait-for-dri-devices-rules-1.ebuild b/sys-block/wait-for-dri-devices-rules/wait-for-dri-devices-rules-1.ebuild
new file mode 100644
index 000000000000..cd2f21b65124
--- /dev/null
+++ b/sys-block/wait-for-dri-devices-rules/wait-for-dri-devices-rules-1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit readme.gentoo-r1 udev
+
+DESCRIPTION="Udev and systemd rules to wait for dri devices"
+HOMEPAGE="https://gitlab.com/pachoramos/wait-for-dri-devices-rules"
+SRC_URI="https://gitlab.com/pachoramos/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ sys-apps/systemd
+ virtual/udev
+"
+BDEPEND=""
+
+DOC_CONTENTS="
+ Feel free to modify
+ /etc/systemd/system/display-manager.service.d/10-wait-for-dri-devices.conf
+ according to your needed cards."
+
+src_install() {
+ udev_dorules udev/rules.d/99-systemd-dri-devices.rules
+ insinto /etc/systemd/system/display-manager.service.d/10-wait-for-dri-devices.conf
+ doins systemd/system/display-manager.service.d/10-wait-for-dri-devices.conf
+ einstalldocs
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ udev_reload
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ udev_reload
+}