summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20190709.ebuild')
-rw-r--r--sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20190709.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20190709.ebuild b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20190709.ebuild
deleted file mode 100644
index 4b06dfa49939..000000000000
--- a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20190709.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit mount-boot readme.gentoo-r1
-
-DESCRIPTION="Raspberry Pi (all versions) bootloader and GPU firmware"
-HOMEPAGE="https://github.com/raspberrypi/firmware"
-LICENSE="GPL-2 raspberrypi-videocore-bin"
-SLOT="0"
-
-if [[ "${PV}" == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/raspberrypi/firmware"
- EGIT_CLONE_TYPE="shallow"
-else
- SRC_URI="https://github.com/raspberrypi/firmware/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="-* ~arm"
- S="${WORKDIR}/firmware-${PV}"
-fi
-
-RESTRICT="binchecks strip"
-
-pkg_preinst() {
- if [ -z "${REPLACING_VERSIONS}" ] ; then
- local msg=""
- if [ -e "${D}"/boot/cmdline.txt -a -e /boot/cmdline.txt ] ; then
- msg+="/boot/cmdline.txt "
- fi
- if [ -e "${D}"/boot/config.txt -a -e /boot/config.txt ] ; then
- msg+="/boot/config.txt "
- fi
- if [ -n "${msg}" ] ; then
- msg="This package installs following files: ${msg}."
- msg="${msg} Please remove(backup) your copies durning install"
- msg="${msg} and merge settings afterwards."
- msg="${msg} Further updates will be CONFIG_PROTECTed."
- die "${msg}"
- fi
- fi
-}
-
-src_install() {
- insinto /boot
- cd boot || die
- doins bootcode.bin fixup*.dat start*elf
- doins *.dtb
- doins -r overlays
- newins "${FILESDIR}"/${PN}-0_p20130711-config.txt config.txt
- newins "${FILESDIR}"/${PN}-0_p20130711-cmdline.txt cmdline.txt
- newenvd "${FILESDIR}"/${PN}-0_p20130711-envd 90${PN}
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}
-
-DOC_CONTENTS="Please configure your ram setup by editing /boot/config.txt"