summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/silo/silo-1.4.14_p20170829.ebuild')
-rw-r--r--sys-boot/silo/silo-1.4.14_p20170829.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sys-boot/silo/silo-1.4.14_p20170829.ebuild b/sys-boot/silo/silo-1.4.14_p20170829.ebuild
index dde2b3c9a733..e62265f8848c 100644
--- a/sys-boot/silo/silo-1.4.14_p20170829.ebuild
+++ b/sys-boot/silo/silo-1.4.14_p20170829.ebuild
@@ -29,7 +29,9 @@ src_prepare() {
sed -i -e "s/1.4.14/1.4.14_git20170829/g" Rules.make || die
# Fix build failure
- sed -i -e "s/-fno-strict-aliasing/-fno-strict-aliasing -U_FORTIFY_SOURCE -mcpu=v9/g" Rules.make || die
+ # -fno-PIC is needed to shrink silo size back to manageable on
+ # profiles where gcc has -fPIC default (via --enable-default-pie).
+ sed -i -e "s/-fno-strict-aliasing/-fno-strict-aliasing -U_FORTIFY_SOURCE -mcpu=v9 -fno-PIC/g" Rules.make || die
# Don't strip ieee32.b during compile
sed -i -e '/^ $(STRIP) ieee32.b/d' first/Makefile || die