summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/silo')
-rw-r--r--sys-boot/silo/Manifest1
-rw-r--r--sys-boot/silo/silo-1.4.14_p20170829.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/sys-boot/silo/Manifest b/sys-boot/silo/Manifest
index fee880417db4..8f3abcfcba25 100644
--- a/sys-boot/silo/Manifest
+++ b/sys-boot/silo/Manifest
@@ -1,3 +1,4 @@
+DIST silo-1.4.14_p20170829.tar.gz 183612 BLAKE2B 88fb4b0ce4e9b8fa9518bcb6226f4fe9ec7011bf3f73d9f0f1562ff837217ca8d54ee783eed0b50096b009fc56527be8e4211623f5b0e4ef5372c38c0fe304f1 SHA512 bda31084ba2ee5b01d331fd390cbccf039dc812debe25f3af97dd5d2855668cbe7e160dee4ca45c16af1fa4aa86224daf3b474fd49b22a8b7f453584a12f3c2b
DIST silo_1.4.14+git20100228-1.diff.gz 10143 BLAKE2B 4282de2900dfa670164ab9c7d64c7793cb5a132fda015750355bad9d94269c223f850d23fe048c215df9653689774dadd8f9cbbdd2919751e574f00b10053e08 SHA512 7209fd4fe65d7d72866ce41d25498e8369f59b51833550ecf9ae84badce33e82eccf97835558d560ca9937ebf37d0de99da7876ee4de1bafbe96e931c6d72cf0
DIST silo_1.4.14+git20100228.orig.tar.gz 738325 BLAKE2B 5e5e221a9df91b94523c366a9f6ab2d195567e9f2938f141d93750a2fd15ec3cf657ca48155ea1113c7b6db011953fa15c1c6fd05759d7bc47cfc274c43424da SHA512 aa119893695fe0ce5eb30c7a461aa77b0f8935b1e2bcff9f83b232aad8b44cce72662c7c6716c61ea914dd5217edaf8d0e01b363010a2f7d9be9ac80a666bb77
DIST silo_1.4.14+git20120226-1.diff.gz 10389 BLAKE2B ad2f6dfdb468a81b71f1f9b43668d162ca946278b03ce115527712beb49c5319e1e285df7e0fa45bc126264b6c35cb2e950184c0647da3a990e087c6dc28fbca SHA512 0dd39461357f862bc0eb7d0b4db8e3e9acadb30f70c8c638b1adef6f6c306d0c475bf59e29c72a91594fcbf544c80e05e5293b857265d4cd579696f10993483b
diff --git a/sys-boot/silo/silo-1.4.14_p20170829.ebuild b/sys-boot/silo/silo-1.4.14_p20170829.ebuild
new file mode 100644
index 000000000000..dde2b3c9a733
--- /dev/null
+++ b/sys-boot/silo/silo-1.4.14_p20170829.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit mount-boot flag-o-matic toolchain-funcs vcs-snapshot
+
+MY_SNAPSHOT="${PN}-2506051d55dd5cb9fe10b4e978e22fa00363044b"
+
+DESCRIPTION="SPARC/UltraSPARC Improved Loader, a boot loader for sparc"
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/davem/silo.git/snapshot/${MY_SNAPSHOT}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://git.kernel.org/?p=linux/kernel/git/davem/silo.git;a=summary"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="-* ~sparc"
+IUSE=""
+
+DEPEND="sys-fs/e2fsprogs
+ sys-apps/sparc-utils"
+RDEPEND=""
+
+ABI_ALLOW="sparc32"
+
+src_prepare() {
+ default
+
+ # Set the correct version
+ sed -i -e "s/1.4.14/1.4.14_git20170829/g" Rules.make || die
+
+ # Fix build failure
+ sed -i -e "s/-fno-strict-aliasing/-fno-strict-aliasing -U_FORTIFY_SOURCE -mcpu=v9/g" Rules.make || die
+
+ # Don't strip ieee32.b during compile
+ sed -i -e '/^ $(STRIP) ieee32.b/d' first/Makefile || die
+}
+
+src_compile() {
+ filter-flags "-fstack-protector"
+
+ emake CC="$(tc-getCC)" \
+ STRIP="$(tc-getSTRIP)" \
+ NM="$(tc-getNM)" \
+ LD="$(tc-getLD)"
+}
+
+src_install() {
+ default
+
+ dodoc first-isofs/README.SILO_ISOFS docs/README*
+
+ # Fix maketilo manpage
+ rm "${D}"/usr/share/man/man1/maketilo.1
+ dosym tilo.1 /usr/share/man/man1/maketilo.1
+}
+
+pkg_postinst() {
+ mount-boot_pkg_postinst
+ ewarn "NOTE: If this is an upgrade to an existing SILO install,"
+ ewarn " you will need to re-run silo as the /boot/second.b"
+ ewarn " file has changed, else the system will fail to load"
+ ewarn " SILO at the next boot."
+ ewarn
+}