summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/unetbootin/Manifest1
-rw-r--r--sys-boot/unetbootin/unetbootin-681.ebuild113
2 files changed, 114 insertions, 0 deletions
diff --git a/sys-boot/unetbootin/Manifest b/sys-boot/unetbootin/Manifest
index a32b84281cc1..27e5e95bad9d 100644
--- a/sys-boot/unetbootin/Manifest
+++ b/sys-boot/unetbootin/Manifest
@@ -3,3 +3,4 @@ DIST unetbootin-661.tar.gz 16257579 BLAKE2B 2f92cf286c8010a80d4d4cc48a7ece55e159
DIST unetbootin-675-qt5.patch.xz 7636 BLAKE2B f8c475491e6cf0557a192380726376c1dadba2e52478139d42023e867de86c5c1727719fa123fb412dbb20fca5763a3192889618e75ef6d8bba2d20eb1cf9403 SHA512 da636a3f6cd6a45d6786d92e94741d74f6c5de7d74570af45eac08718a822cdef5baac6c62d7ed68a788e9518e050f3a48a46f8f374c07e0b4c0d90c3613185d
DIST unetbootin-675.tar.gz 23221792 BLAKE2B fb3a6fce9d2a47b83e2e4c1a579d20594a637215b7c6456d6b0a59a592da660b13bdbea52aa5a4f902e410e9d0e2d447d085f040d321029a96b7ff957a59d11e SHA512 7cb5da4a876125ff010fc6a5aab2b5bb6eeec0f1ac6f2dd86efa2c3eaebaedff8c2167f9dc77053936955703cd2a98dd11a84b8de930dcfc1c2b0f6aeaf7ee61
DIST unetbootin-677.tar.gz 23479226 BLAKE2B b5a5b111c5f96cc603975f535b55dd8e6191cc92972f54591ae6673394abae15e2652f737b8dc02f8b26a1247a9663cbda3b0d2d7b8b8dfe9eb117711f08d053 SHA512 f86b25dabc27f12bdb65a590c4ffa25aa509a78aa29cecde73918d8bc36dc3e6597b2b7e1803f7fa86a884347506e9c25b361ce89c26e0f6449e0c1ef29355d1
+DIST unetbootin-681.tar.gz 23481527 BLAKE2B b8c75156539a07bdacf1185ed898867b1e3df91a87486b7291e4bffc0c754c1ea3fe8a13a2ade5507a886e05904daa90877d29bd72ae1c353cb20dd64264e391 SHA512 9ac8c51f3b65bd6f051caa0270c239ec8aaabb2d3b92bec7b18803d3dcfdbe2bbca4e25124477f4e7b83ee10ba2aa08cdf055e8c9bb042cbebcd3ff6a96315b9
diff --git a/sys-boot/unetbootin/unetbootin-681.ebuild b/sys-boot/unetbootin/unetbootin-681.ebuild
new file mode 100644
index 000000000000..4f0db3c3d742
--- /dev/null
+++ b/sys-boot/unetbootin/unetbootin-681.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit desktop flag-o-matic qmake-utils xdg-utils toolchain-funcs
+
+DESCRIPTION="UNetbootin installs Linux/BSD distributions to a partition or USB drive"
+HOMEPAGE="https://github.com/unetbootin/unetbootin"
+SRC_URI="
+ https://github.com/unetbootin/unetbootin/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~jer/${PN}-675-qt5.patch.xz
+"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+UNBI_LINGUAS="
+ am ar ast be bg bn ca cs da de el eo es et eu fa fi fo fr gl he hr hu id it
+ ja lt lv ml ms nan nb nl nn pl pt_BR pt ro ru si sk sl sr sv sw tr uk ur vi
+ zh_CN zh_TW
+"
+
+for lingua in ${UNBI_LINGUAS}; do
+ IUSE="${IUSE} l10n_${lingua/_/-}"
+done
+
+S=${WORKDIR}/${P}/src/${PN}
+
+COMMON_DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+"
+BDEPEND="
+ ${COMMON_DEPEND}
+ dev-qt/linguist-tools:5
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ app-arch/p7zip
+ sys-boot/syslinux
+ sys-fs/mtools
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-675-desktop.patch
+ "${WORKDIR}"/${PN}-675-qt5.patch
+)
+
+src_prepare() {
+ default
+
+ # QA check in case linguas are added or removed
+ enum() {
+ echo ${#}
+ }
+ [[ $(enum ${UNBI_LINGUAS}) -eq $(( $(enum $(echo ${PN}_*.ts) ) -1 )) ]] \
+ || die "Numbers of recorded and actual linguas do not match"
+ unset enum
+
+ # Remove localisations
+ local lingua
+ for lingua in ${UNBI_LINGUAS}; do
+ if ! use l10n_${lingua/_/-}; then
+ sed -i ${PN}.pro -e "/\.*${PN}_${lingua}\.ts.*/d" || die
+ rm ${PN}_${lingua}.ts || die
+ fi
+ done
+ append-cflags -DNOSTATIC
+ append-cxxflags -DNOSTATIC
+}
+
+src_configure() {
+ sed -i -e '/^RESOURCES/d' unetbootin.pro || die
+
+ export QMAKE_CXX="$(tc-getCXX)"
+
+ UNBN_QTPATH="$(qt5_get_bindir)/"
+ "${UNBN_QTPATH}"lrelease ${PN}.pro || die
+
+ eqmake5 ${PN}.pro || die
+}
+
+src_install() {
+ dobin ${PN}
+
+ domenu ${PN}.desktop
+
+ for file in ${PN}*.png; do
+ size="${file/${PN}_}"
+ size="${size/.png}x${size/.png}"
+ insinto /usr/share/icons/hicolor/${size}/apps
+ newins ${file} ${PN}.png
+ done
+
+ local lingua
+ for lingua in ${UNBI_LINGUAS}; do
+ if use l10n_${lingua/_/-}; then
+ insinto /usr/share/${PN}
+ doins ${PN}_${lingua}.qm
+ fi
+ done
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}