summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/libcman/libcman-3.1.5.ebuild')
-rw-r--r--sys-cluster/libcman/libcman-3.1.5.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-cluster/libcman/libcman-3.1.5.ebuild b/sys-cluster/libcman/libcman-3.1.5.ebuild
new file mode 100644
index 000000000000..f570f8425f02
--- /dev/null
+++ b/sys-cluster/libcman/libcman-3.1.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit linux-info multilib toolchain-funcs versionator
+
+CLUSTER_RELEASE="${PV}"
+MY_P="cluster-${CLUSTER_RELEASE}"
+
+MAJ_PV="$(get_major_version)"
+MIN_PV="$(get_version_component_range 2-3)"
+
+DESCRIPTION="Cluster Manager Library"
+HOMEPAGE="https://fedorahosted.org/cluster/wiki/HomePage"
+SRC_URI="https://fedorahosted.org/releases/c/l/cluster/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="static-libs"
+
+DEPEND=">=sys-kernel/linux-headers-2.6.24"
+RDEPEND="!sys-cluster/cman-lib"
+
+S="${WORKDIR}/${MY_P}/cman/lib"
+
+src_configure() {
+ cd "${WORKDIR}/${MY_P}"
+ ./configure \
+ --cc=$(tc-getCC) \
+ --cflags="-Wall" \
+ --libdir=/usr/$(get_libdir) \
+ --disable_kernel_check \
+ --kernel_src=${KERNEL_DIR} \
+ --somajor="$MAJ_PV" \
+ --sominor="$MIN_PV" \
+ --cmanlibdir=/usr/$(get_libdir) \
+ --cmanincdir=/usr/include \
+ || die "configure failed"
+}
+
+src_install() {
+ default
+ use static-libs || rm -f "${D}"/usr/lib*/*.a
+}